Forced to frequently reinstall Freedome

Since a couple of month ago Freedome starts after 2 to 4 days to block access to the internet when turned on. I notice this already when I turning on Freedome from off to on.  It takes much longer time to turn Freedome on (from Off to ON)  when the problem occures.  Non of my browser (Edge, Firefox, Chrome) than have internet access. I have to turn off Freedome and download the Freedome exe instalation file and intall the program again. Now Freedome works again for a couple of days.  After a few days the problem is back again.

On my other decives, Android mobiles, I have now problems with Freedome.

Yesterday I installed the Windows 10 Creator update and today I hade the problem gain. 

Reinstalling Freedome solved the issue but I assume in 2 to 4 days I have the problem again

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Zitrone,

     

    1. Is there any error message which you see in the browsers when you try to connect to the internet?

    2. Does this happen to all the locations? If not, in which location do you see this issue?

    3. Does it help if you change location and reconnect again without uninstalling?

     

    Please also let us know the AV program installed on your computer.

     

  • ZitroneZitrone Posts: 7

    Hi,

    1) No. no specifiy message beside that the page can't be accessed.

    2) Yes it happens also when I chance locations

    3) No

     

    I have F-Secure "FS-Proction" as AV on my computer

     

    Win10 64 bit, i7  6700K; Asus mainboard Z170P, Grafic card ASUS Nvidia GeForce 970

    All drives and BIOS are up to date.

     

  • DumelaDumela Posts: 6

    I have also started to have ethernet connectivity issues.  I heavily suspect they are related to Freedome, but its really hard to tell.  My ethernet adapter sometimes can be reset, which fixes it.  But it goes out again after a while.  This suddenly occured after installing Freedome on my two home desktops with Windows 10.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @Dumela, does it happen with Windows 10 Creator edition?

     

    Thanks for your update, @Zitrone. Can you please monitor it and if it happens again, kindly get in touch with our support team via chat/phone to investigate it further? It might need further investigation with the logs.

  • DumelaDumela Posts: 6

    I don't know what the "creators edition" is.  I'm running the most recent version of Windows 10 I can.

     

    - JP

  • ZitroneZitrone Posts: 7

    Win10 Creator is the big update from biginning of this month. It can take several month until all users get it via normal Windows update.  (Windows version 1703. Build 15063.138) (You can check your version by entering Winver into the Search field beside the start buttom.)

    Today I had a chat seession with F-Secure support. As a result I had to sent a fdiag report per E-Mail to the report team. Now I am waiting for the investigation outcome which can take a couple of days.

  • LakshLaksh Posts: 4,444 Community Manager

    Thanks for the update, Zitrone! You can always followup or reply to the support case for further information.

  • ZitroneZitrone Posts: 7

    I got an answer but have not tried the solution as I have got a problem with my Acronis Back-Up program. First I have to solve that new issue so I can make a system back-Up before I try the by F-secure support oulined solution.

    Support answered: Through the sent in logs they noticed the Freedome TAP driver turn to have an invalid IP address (169.254.147.132). The TAP driver also fails to communicate to your router/modem gateway.

     

    Please try these workaround, reinstall F-Secure Freedome, and let us know if it helps.
     
    1) Uninstall F-Secure Freedome.
    2) Try to reset TCP/IP stack by using Easy-fix tool from here:
     
     
    Note: Please run the tool with admin rights.
     
    3) Restart your computer.
     
    4) Reinstall F-Secure Freedome.
     
    Please monitor the issue for a few days.

     

  • ZitroneZitrone Posts: 7

    As i was on vacation I could not test the solution from F-Secure support until now.

    It worked for 2 days but than the problem was there again

    In the solution it is stated: Please run the tool with admin rights.

    I do not know how to unzip a cab file. The microfoft file is a cab file.

    I excecuted the tool  anyhow and it seams to function.

    Lets see what support will reply

     
This discussion has been closed.