Freedome VPN will not connect - Windows 10

My Freedome VPN will not connect. I just installed it yesterday.  It worked for a few hours, until I shut my computer down for the night.  This morning, when I booted up and tried to start it, it wouldn't connect.  It tries to for some time, then gives up and shows Not Connected message.  I've re-installed it as well as trying all the other things suggested in other posts for people having the same problem. Nothing has worked.  When I go into  Network Connections it says that my "Network Cable is Unplugged".  Of course this isn't correct. All of my network cables are just fine.  I don't know what to do next. 

Any help would be appreciated.  

Comments

  • TapsuccaTapsucca Posts: 501 Former F-Secure Employee

    Hi @TerryG and thank you for your message.

     

    Is the Internet connection working when Freedome is turned off?

     

    Can you try to connect to another network? Does it work there?

     

    Have you tried to change the location to a different one? What location you are currently using?

     

     

  • TerryGTerryG Posts: 2

    Hi,

    Yes, my internet connection works just fine when I turn Freedome off.
    I've been trying to connect with the East Coast location, which is the recommended location.  Although I've tried several other locations too.  None work.

    I've only installed Freedome on my PC, which uses a wired connection.  I haven't tried it on Wifi yet.  I will install it on my tablet to see if it works.

  • paulg1paulg1 Posts: 9

    im also having the same problem in windows 10 home net works fine when freedome turned 0ff but when turned on nothing can anyone help?

  • paulg1paulg1 Posts: 9

    ive been trying to sort this by reading other posts about it but cannot still get freedome to connect to any website,works fine when its turned off.is there a fix yet?

  • PeterzPeterz Posts: 3

    Same problem. We have been using Freedome for 3 years and suddenly one morning receive "Network Cable is Unplugged" etc. Internet working fine with Freedome off. Have checked that our anti-virus/firewall program allows Freedome, tried re-installing and according to Windows 7 "Network Connections" the "FreedomVPNConnection" is working. Any ideas?

  • PeterzPeterz Posts: 3

    Working now. We uninstalled the Freedome Tap driver (in "Network Connections"), turned computer off and unplugged power for a little while, turned PC

  • PeterzPeterz Posts: 3

    Working now. We uninstalled the Freedome Tap driver (in "Network Connections"), turned computer off and unplugged power for a little while, turned PC back on and all connections are working again. Hope it helps someone else.

  • Unfortunately didn't work for me.

  • LakshLaksh Posts: 4,440 Community Manager

    Hi @dawson1956 and @paulg1,

     

    Could you confirm if there is Kaspersky Secure connection or Kaspersky Internet Security running on your PC's along with Freedome?

     

    Also, is there any pending Windows Updates on the PC? Could you try to update any pending Windows Updates and recheck the connection?

  • Kaspersky on the PC (but with secure connection not used) before and after recent problems. Yesterday, I also unchecked the secure connection options in Kaspersky to make sure it was not background running. I did get some internet access with Freedome on but connection to sites is slow and will sometimes only return text with no graphics.

    The machine is fully updated. Don't know if relevant but I did a Tracert that have many more hops to a site than I would have expected and with some timeouts.

  • paulg1paulg1 Posts: 9

    i have kis but not secure connection no outstanding windows updates

  • paulg1paulg1 Posts: 9

    is there anything yet on a fix? iturned of kis and tried it but made no difference

  • paulg1paulg1 Posts: 9

    er looking at kasperskis tech support pages it seems the problem relates to an update they did,so guess its down to them to fix it?

  • have you a link to the page? Thanks

     

  • Thanks have read the posting and did need a cuppa. Still not sure if it is the full answer. I've now used the Kaspersky removal tool to get rid of the secure connection manager but still no improvement. There may be some other registry settings I need to look at, perhaps F-Secure people might advise.

  • MrCMrC Posts: 4

    Very interesting.

     

    There is a link in the post (on page 3 in a post by rangrisano) for going back to Kaspersky 2016.

    Uninstall Kaspersky 2017 then re-start and install Kaspersky 2016.  Perform an update of databases (which is a hefty download of ~93Meg) and VPN works fine.  Problem seems to be with the latest Kaspersky patch (patch d for 2017) rolled out around 13 March.  This timing fits with when my problems started.

     

    All sorted now.

    Skiddommahon
  • mmahonmmahon Posts: 1
    I'm currently impacted by this bug/conflict. I'm just going to turn freedome off until a patch is released that resolves the issue.
  • You need to contact Kaspersky for a fix as the problem is caused by them.

  • paulg1paulg1 Posts: 9

    problem is they dont seem to ne in a hurry to fix it

  • Have you logged it as a problem with them? Kaspersky provided me with a workaround within a few days. F-Secure will not be able to provide a solution to what Kaspersky admit as being their problem.

     

  • MikemanMikeman Posts: 1

    I just encountered the same problem.

     

    - F-secure freedome with F-secure safe.

     

    Connection was working when Freedome turned off. I updated F-secure safe "manually" and after virus database was updated freedome was connecting and working again.

This discussion has been closed.