F secure doesn`t let me in Firefox 64x

Hello all,

 

I`m a first user of f secure, and it works almost perfect for me.

I`m using firefox 64 bit, and it seems to me that f secure doesn`t let me in to my beloved web sites???

Is this normal behaviour from f secure, and most i use firefox 32 bit or what....

I`m using the latest version of firefox  51.0.1 (64 bit)

Comments

  • UkkoUkko Posts: 3,142 Superuser

    Hello,

     

    Sorry for my reply.

    But how it visible with your experience? Pages blocked by F-Secure (like if there is F-Secure blockpage)? Or when F-Secure is enabled - browser do not show pages?

     

    With my recent experience about Firefox 64bit and F-Secure there was all Ok. But maybe it was not latest build of Firefox...

  • FlyingDutchmanFlyingDutchman Posts: 9 Explorer

    Or when F-Secure is enabled - browser do not show pages?

     

    This is exactly what happens.

    I`ve looked in F-Secure if there is something i overlooked, but can`t find nothing.

    Maybe the firewall from windows ????

    I`m not sure if that me be the problem, but now i am using my laptop with linux so i

     can do something.

    But you understand that this is not the way it should be.

  • UkkoUkko Posts: 3,142 Superuser

    Yes, this not nice situation....

     

    But I re-check it and with my experience (there is also latest build of Firefox) - I able to open webpages with F-Secure installed under my system. But there is also Firefox 32bit installed (if it can be related - because browser settings "switched" between them). So, at least there can be normal work-status for Firefox 64bit/F-Secure.

    Also - if you mean - that not all connections are blocked, but certain ones. Maybe this pages randomly marked as harmful-rated (under the F-Secure Security Cloud). So - with this situation - it can be reported there: https://www.f-secure.com/en/web/labs_global/submit-a-sample#sample-url  (as re-rate for certain webpages - if f/p blocking).

     

    If it will be valid for your experience - maybe you able to get support directly from F-Secure by their support channels ( https://www.f-secure.com/en/web/home_global/support - there is chat/call-phone options); It will be possible - if just Firefox do not show pages, but other browsers work normally with your system and F-Secure installed.

     

    Or maybe someone else can to be with this trouble and will response there. There was previously some troubles with Firefox 64bit and F-Secure.

     

    Sorry for my reply.

     

  • FlyingDutchmanFlyingDutchman Posts: 9 Explorer

    Thanks for your reply,

     

    Other browsers should mabye work fine, but not for me.

    I use only firefox (64) as a browser, because it also works fine for me on linux.

    But i need windows to do some things that i can`t do on linux (because im not a linux geek).

    But with this little problem i can`t do my work, and so now the only option for me now is

    to delete f-secure from my desktop pc.

    Also to mention that with my system ALL connections are down with f-secure, also my nas.

    The problem to connect to my ASUSTOR nas, is a new discovery from yesterday evening.

    But this little problem is solved with f-secure disabled ???

    Maybe if  i give you my pc installation setup, this can be helpful.

    I`ve got : Asus motherbord Z97-Pro, Nvidia 980 GTX, Mushkin 16GB Memory, Intel 4790K Cpu, Cooler Master Watercooling sytem Nepton 280 L and i use Windows 10 Pro.

    All drivers of my system are up to date.

    The only thing that doesn`t work well is ...........f-secure.

  • UkkoUkko Posts: 3,142 Superuser

    Hello,

     

    So, not sure about potential reasons.

     

    But which F-Secure solution you tried to use? Does it F-Secure AV, F-Secure Internet Security or F-Secure SAFE? And if your experience about one of this solutions - does there latest builds of them (like if directly from F-Secure or ISP)? Usually it possible to check by "tray-picture" right-click and "About"-string.

     

    Or there something like F-Secure Freedome (kind of VPN-software-service)?

    -------

    Because - basically - solutions like F-Secure AV/IS/SAFE should not trigger such kind of trouble (at least - I can not to think about certain reasons from first; also with meanings - that disabling?! F-Secure - is helpful). At least latest builds of F-Secure solutions for home users.

    But maybe it blocking critical software under the system.

    There is possible some steps to re-check situation (but all of them - can be just my suggestions), but most helpful can be just get direct support from F-Secure certain channels (or maybe there is can be response from F-Secure Community team about known related troubles);

     

    Also you able to check this page:

    https://help.f-secure.com/index.html

    Where can be "Help/About":  how to use some of features for certain F-Secure's solutions; It can be helpful about to check "if there is something blocked by DeepGuard" or how to exclude known folders/directory/files.

     

    But maybe... if there F-Secure SAFE (or F-Secure IS) - you able to re-check Browsing Protection settings. There can be Content Blocker features like "limit network usage", "category"-blocking. If this restriction with "work"-status and limited... possible that connections are blocked. 

     

    Sorry for my reply. and that this reply too much long. Smiley Sad

     

     

    But if we talk about something F-Secure Freedome. Maybe this kind of trouble possible there.

    And can be based on situation, when you restart your system with "Freedome active status". But most likely with this setting - Windows should trigger "connection"-trouble about Network-status.

     

     

    Patzie
This discussion has been closed.