Using a NAS in a local network while Freedome is ON?

Hi! Im not quite sure how Freedome works... But if im using Freedome on my Mac, can i connect to my NAS (locally) or does the trafic goes through VPN?

 

Because it seems to be that when i connect to my router, it takes longer to connect to the dashboard than without VPN.  And i saw that i lost all mapped drives (NAS) from my Mac when Freedome is on. 

 

Is there a possibility to connect local devices without tunneling it through VPN?

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Cane,

     

    As per this article, you can connect to your local devices without any special action required for Freedome. Are you able to connect to the devices when Freedome is off?

     

  • CaneCane Posts: 7

    Yes, i can connect to the NAS (locally, in the same network) fine without Freedome. 

     

    When Freedome is ON, the connection is slow though. Thus i was thinking if the vpn is affecting or even tunneling the trafic?? It happens on all my devices: Macbook, iphone and ipad.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Cane,

     

    Sorry for getting back to you late. I was checking with the product team for further steps.

     

    Could you please provide the following information in order to check further?

    - Network configuration for the devices (IP addresses etc)

    - Make and model of the NAS device

    - If the IP addresses are public, do you have a firewall or NAT that blocks access from the Internet to the NAS device?

  • Hi,

     

    Got the same issue, this was working fine earlier.

    Looks like local traffic routed through Freedome.

     

    Any configuration changes on F-Secure side?

     

    Reproducable with two different pc's. / Windows 10

    Got a Synology NAS (which model I don't think matter)

     

    Tracert with Freedome activated:

     

    Tracing route to DISKSTATION [192.168.100.126]
    over a maximum of 30 hops:

    1 gateway.freedome-vpn.net [198.18.8.1] reports: Destination host unreachable.

     

    Tracert without Freedome activated:

     

    Tracing route to DISKSTATION [192.168.100.126]
    over a maximum of 30 hops:

     

    1 <1 ms <1 ms <1 ms DSL_WLAN-Router [192.168.100.1]
    2 <1 ms <1 ms <1 ms DISKSTATION [192.168.100.126]

     

    Hoppetosse
  • I also have the same problem with a Buffalo NAS.  When Freedome is ON I can't see the share at all.  As soon as I turn it off it reappears.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi,

     

    Could you provide the following information about the network which might help the product team about this issue - IP addresses for the devices, netmasks, default gateways

     

    The traceroute shows that the traffic doesn’t go through Freedome, but we'are suspecting there may be, for instance, wrong netmask that could explain this.

  • I am really sorry but being a bit of a technophobe, I'm not sure how to get all that information.  If you were able to give me a few steps to get this information I will get it all on here.  Thank you!  :)

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @SparkyMark,

     

    I found this webpage with steps from Google - http://web.mit.edu/rama/www/IP_tools.htm - these might help you to find the necessary information.

  • Thank you!  :)

     

    So...  not exactly sure what info to provide but here goes:

     

    NAS is on 192.168.0.3

     

    With Freedome OFF:

    IPv4 address: 192.168.0.15

    Subnet mask: 255.255.255.0

    Default gateway: 192.168.0.1

     

    With Freedome ON:

    IPv4 address: 192.168.0.15

    Subnet mask: 255.255.255.0

    Default gateway: 192.168.0.1

     

    Ethernet adaptor FreedomeVPNConnection now has following when ON:

    IPv4 address: 198.18.1.58

    Subnet mask: 255.255.255.252

    DHCP Server: 198.18.1.57

     

    Is this what is required?  Does this help?  If not, I am going to have to uninstall Freedome and get the money back within the 28 day trial - I really, really don't want to do that.

     

     

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @SparkyMark,

     

    This is the information which the Product team wanted. I have passed on your recent post to them for inputs. Once we have any information further, we will keep you posted.

  • Thank you!  :)

     

    I should also add that I am unable to send email from Windows Live Mail when Freedome is switched on.  It just sits there connecting and doing nothing.  As soon as I switch Freedome off, the email sends.

     

    So not sure if it is also blocking certain ports, SMTP, etc...?

  • TapsuccaTapsucca Posts: 501 Former F-Secure Employee

    Hi @SparkyMark and thank you for your message.

     

    I hope this article will help you with the email sending issues while Freedome is turned on:

     

    https://community.f-secure.com/t5/F-Secure/How-can-I-send-emails-when/ta-p/81640

  • Awesome, thank you, I will try that.  And apologies for not searching for that before raising it here.

  • Email fixed.  Thank you!  :)

    Tapsucca
  • Apologies for raising another potential issue (or hopefully user "not knowing what they are doing again") but I found today that I had to switch Freedome off on our tablet in order to access the Sky Q wireless network so that we could watch programmes from the main box on it.  Once I switched Freedome off on the tablet, it was able to straight away access the Sky Q box via the wifi network and we could watch programmes.

     

    Is it something I am doing wrong again?

  • TapsuccaTapsucca Posts: 501 Former F-Secure Employee

    Hi @SparkyMark and thanks again for you message.

     

    You could try to add the Sky Q wireless network as trusted network from Freedome settings:

     

    Freedome->Three lines in left upper corner->Settings->Trusted Wi-Fi networks

  • Thank you again!  Worked awesomely.  Smiley Wink

     

    On the previous issue of not being able to see the NAS when Freedome was switched on...  I decided to try using the IP address to connect to the share on the NAS rather than the NAS name.  This appears to have worked and I can now see the NAS via the IP while Freedome is switched on.

     

    It would still be good to know why it doesn't work by name though...

  • TapsuccaTapsucca Posts: 501 Former F-Secure Employee

    Hi @SparkyMark ,

     

    I am  happy to hear it worked for you.

     

    The other thing is still under investigation and we will get back to you as soon as we have the results.

  • TapsuccaTapsucca Posts: 501 Former F-Secure Employee

    Hi @SparkyMark,

     

    Now I got the answer from our Freedome Team:

    The devices in the local network are accessible, but only with IP address as Freedome must take over the DNS service to avoid the DNS leaks. If the user wants to access local devices by names, he must add those names to the hosts file (C:\Windows\System32\drivers\etc\hosts) this way:

     

    192.168.123.123    my-nas-box

    192.168.123.124    my-network-printer

    192.168.123.125    my-fridge

     

    (The IP address must be the device’s IP address and the name is naturally the name the user wants to use for his device)

     

This discussion has been closed.