F-secure update

After a >Freedome update I cant turn protection on and I get a failure message saying there is a driver failure and the PC have to be restarted which dont help. Runf windows 10

Comments

  • bikbak
    bikbak Posts: 7

    Solved the problem by using another VPN provider, just to bad support

    dick99
  • bikbak
    bikbak Posts: 7

    Hi, 

     

    No it is not solved

  • bikbak
    bikbak Posts: 7

    Here is what worked for me:

     

    Set up instructions:

    1. Uninstall Freedome.

    2. Clean registry with Ccleaner

    3. Download Freedome installer

    4. Locate the downloaded installer and right-click on it and click "Properties"

    5. Go to the "Compatibility" tab

    6. Under the Compatibility tab, click on the check box to enable Compatibility mode.

    7. Select any Windows 7 compatibility mode from the drop-down menu.

    8.  At the bottom of the Compatibility tab, there's also a check box under "Privilege Level," make sure to check it as      well to run the installer in elevated admin mode.

    9. Click OK and then try installing Freedome anew.

     

    It is the answer I would expect from a product support????

  • Laksh
    Laksh Posts: 4,444 Former F-Secure Employee

    Hi bikbak,

     

    Welcome to our Community! Have you contacted our support regarding your issue? If yes, could you pass me the case details so that we can check on the response for your issue?

     

     

This discussion has been closed.
Product & Pricing Info