update problem

hi i just looked through the update list and saw that F-Secure Network Interception Framework Update 2017-01-02_01 due to update on the 7th hadn't installeded what can i do?

Comments

  • SimonSimon Posts: 2,600 Superuser
    Have you tried rebooting your machine?
  • i'll try it again

  • i just tried restarting but it didn't fix it

  • SimonSimon Posts: 2,600 Superuser

    I can only make a few suggestions, until someone from F-Secure comes along:

     

    You can wait another day or so and see if it installs (which may be unlikely, given it's already been sitting there for 7 days).

     

    You could go to the Support Tools page and run FSAUA-reset Tool, followed by fsdbupdate for Windows, and see if that helps.

     

    You could try a reinstallation of F-Secure on top of itself from your SAFE Portal.

     

    You could send in a Support Ticket, attaching an FSDIAG from the Support Tool, and hopefully the tech guys will be able to see what's going on.

  • thanks simon i'll wait and see what someone from f-secure reccommends most

     

    I was also wondering  can anyone tell me what this even does?

    Ukko
  • SimonSimon Posts: 2,600 Superuser

    Have to admit, I wondered that myself.  My guess is, it's something to do with protecting your network (from being hacked?), but if you have strong router and wifi passwords, you should be pretty secure anyway.

  • UkkoUkko Posts: 2,974 Superuser

    Hello,

     

    Sorry for my reply.

     

    Will be good - if there will be normal response from F-Secure.

    I just want to add some words as my suggestion (I also just F-Secure user);

     

    How I can to understand:

     F-Secure Network Interception Framework should provide basic (and common for installation) browsing/network features.

    As additional will provide "updating"-feature for Browsing Protection module (or extensions/addons) with "not required full upgrade" for the installation; like on-the-fly and real-time.

     

    Time to time there can be just "view"-trouble, when list of updates can be with string as "not installed" (when all good in fact);

     

    I think that you able to re-check some points (before/after/during support request by some of steps):

     

    -> Under the Update-window: there should be "View log-file"-string; 

    There will be text-file with some kind of information about; You able to re-check if F-Secure NIF have tries to do "re-install" action and it goes to "trouble" each time; Or just if - there is missing anything about it;

     

    -> If you can to get rating-pictures under the search engines (HTTPS Google, Bing, Yahoo);

    Blocking result for the test page (for check that F-Secure able to block harmful pages) as:  http://unsafe.fstestdomain.com/ 

    And Banking protection triggered under the bank-pages; And when you plug to the "fresh" network (as wi-fi router or modem) - you get the notification about it....

    So most likely that there is can be all OK.  At least common security features work.

     ----

    My installation looks like with proper installed this "component" at this time.

    And extension/addons under the browser (for get search rating pictures) normally work. I think usually updates can be related with small fix-actions for something.

     

    Sorry for my long reply. Smiley SadSmiley Sad

     

    Thanks.

  • thanks, hopefully f-secure will know exactly what to do the weird thing is that on the status page it says that all security features are up to date.

  • VilleVille Posts: 491 F-Secure Employee

    Hi @charmedgirl_121

     

    The Network Intercept Framework provides functionality in our product to scan and block network connections. It's used for Browsing Protection and scanning downloads, for example.

     

    When the update stays in "Not installed" state, you still have the previous version installed, so the product should work quite well. I would recommend trying the "FSAUA-reset" tool that @Simon mentioned. You can find it at ftp://ftp.f-secure.com/support/tools/FSAUA-Reset/.

     

    If that doesn't help, please contact our support and they will guide you through how to fix this situation.

     

    Ville

    (F-Secure R&D)

     

    Ukko
  • thank you Ville

     

    how do i know if this tool is actually functioning cause i'm not sure it is

  • it doesn't seem to have worked i'll contact support the first chance i get
  • @Ville

     

    hi villle i'm not sure whats one but its not attempting the installation anymore but still says  not installed

This discussion has been closed.