No connection since 3rd Jan windows 10



I can no longer connect using Freedome. It states that DNS servers won't reply, that they are either wrong or don't exist. I tried this with multiple destinations, all with the same result. I had an update on my PC monday night, so I assume this has caused the problem.  I never had a problem before with F-Secure, and would really like to continue using this product, so any help would be really appreciated.






  • LakshLaksh Posts: 4,444 Community Manager

    Hi Adam,


    Could we have a screenshot of the error message? Please let us know the version of Freedome installed as well.


  • Adam10Adam10 Posts: 3

    I have uninstalled and re installed the program a couple of times, so the version is the latest one on the website (cant seem to find a version number anywhere)


    Screenshots would be in swedish, but say


    Network diagnostic in windows


    DNS server doesnt answer

     - Computer trying to use a DNS server that is incorrect or does not exist

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Adam10,


    Are you currently located in China?

  • Adam10Adam10 Posts: 3
    No, currently in Sweden
  • LakshLaksh Posts: 4,444 Community Manager

    Hi Adam10,


    Since you have already tried to uninstall and reinstall, please contact our support via phone or chat to check on your issue further.


This discussion has been closed.