Can not register Freedome after hard drive crash...

Kletturinn Posts: 3 New Member

Hi, on December 9. 2016 I bought F-Secure Freedome VPN with 3 licenses.

I have a 12 month 3 device subscription.  I have used all 3 license one on iMac, one on Windows 10 PC and one on iPad.

Everything has work fine on all three devices, and I have no complaint about the product.


My iMac setup is:

Model Name: iMac

Model Identifier: iMac11,3

Processor Name: Intel Core i7

Processor Speed: 2,93 GHz

Number of Processors: 1

Total Number of Cores: 4

macOS Sierra version 10.12.2 newest version.


Well, the situation I am in now began when I was in a need for upgrading my iMac Hard Drive and got me a brand new SSD Drive and put it in. I installed a fresh copy of MacOS Sierra 10.12.2 (same version I had before but on my old Drive) on that SSD Drive and MacOS was functioning great, installed the application from Adobe Creative Cloud, set up my E-mail Client and so forth, everything was fine. I restored from a backup I had, F-Secure Freedome for Mac onto my new SSD.


Here begins the problem…


Fired up F-Secure Freedome for Mac and put in my „Code” and a window opened with the information that I had used all of my licenses. Ok, I needed help with this and I tried yesterday to connect with your Chat channel but did not get any respond. I search the F.A.Q and did find similar cases as mine and it seems to have been solved by the IT people at F-Secure. Please help me.


Picture of what I am talking about.




This discussion has been closed.
Product & Pricing Info