Banking protection no longer working in Firefox after re-install of Internet Security

Hi,

 

After a windows update I was forced to re-install Internet Security because I couldn't open the F-Secure menu in the task bar anymore by right clicking. Now the Banking and Browsing Protection does no longer work - the debug information provided by Firefox suggests that some sort of Windows Service seems to be missing. I resetted the Firefox profile but afterwards the Browser Protection is still there - deactivated. Activating doesn't help either.

 

What can I do else? How can I reset/de-install the Browser Protection and rebuild it?

 

OS: Win 10 Pro 64bit - all updates

Firefox: 50.1.0 64bit - only one AddOn (uBlock)

 

Regards,

Marcus

Accepted Answer

Comments

  • SimonSimon Posts: 2,661 Superuser

    Have you tried re-installing the Browser Extension?   I think you can do that in the Browsing Protection module, but I haven't got it in front of me so I can't be more precise.  Also, does the browser plug in appear to be correctly installed in your Firefox Add-ons?

     

    If you continue to have problems, then often the simplest solution is to reinstall F-Secure completely, using the F-Secure Uninstallation Tool to remove the existing installation, and start again.  

  • A reinstall of F-Secure Internet Security using the Uninstallation Tool *IS* what caused the problem! I doubt that another try will do any better. I resetted my Firefox and the Firefox AddOns completely but that didn't help.

     

    Is there any way to make Internet Security re-install the Browser Protection AddOn?

  • SimonSimon Posts: 2,661 Superuser

    Yes, as I said above, there's a button in the Browsing Protection module in F-Secure to reinstall the Browser Extension.  Make sure Firefox is closed before you try it.  

  • Just to give you an impression what's going on here I document it step by step:

     

    I go the general settings ("Allgemeine Einstellungen"). See here: scrn1.jpg

     

    I select installed applications ("Installierte Anwendungen") that's the only place where the Browser protection shows up. See here:

    scrn2.jpg

     

    I cannot change anything just click on "OK" or cancel ("Abbrechen") in the lower right.

     

    Calling the maintenance center ("Wartungscenter öffnen") produces the following:

    scrn3.jpg

     

    ...which means the re are no current problems.

     

    So the solution you provided doesn't work here. I already tried a second re-install which didn't help either. I have no idea what to do next...

  • SimonSimon Posts: 2,661 Superuser

    OK, apologies, but I don't read the language that screenshot is.  Is that an old version of F-Secure, though, as I haven't seen that launch button for a while.

     

    Further, I see that you have both Internet Security and Anti-Virus on your machine, but do I assume correctly that Anti-Virus isn't currently installed?  If you have both installed, that may present problems.

     

    This what I see when I open my F-Secure (I should point out that this is FS Protection, which is the Beta version of current products, but I believe it is much the same as the latest FS versions in all but the name):

     

    Main interface -

     

    Open.jpg

     

    Click Browsing Protection option at bottom to open BP interface -

     

    BP.jpg

     

    Click Settings -

     

    Reinstall.jpg

     

    As you can see, there is a button to reinstall the browser extension.

     

    I would suggest that you check which version of F-Secure you have, and if not up to date, then update to the latest version, as older versions of FS may not be compatible with latest versions of Firefox.

     

    I would also suggest you check that you don't have both Internet Security and Anti-Virus installed.  Internet Security contains Anti-Virus, so you don't need the stand-alone Anti-Virus as well.  Apologies if I've got that wrong, as I only read and speak English.

  • Hi... OK your screenshots remind me of something...

    First things first: You are right - AV an IS are NOT installed together. I'm a licencse gatherer so I still have some AV licenses but they are not in use at the moment. So on my computer there is only the Internet Security 2016.

     

    Your screenshots remind me of the looks of AV on my Windows 7 Ultimate 64bit machine. That's some time ago. Now I have a freshly installed Windows 10 Pro 64bit on the very same machine. I downloaded the "F-SecureNetworkInstaller.exe" from the F-Secure download section just today! I used the "UninstallationTool.exe" referred to by the F-Secure support here to remove the old installation. The i re-installed using the network installer. You have seen what version is put on my machine. It struck me odd that the looks were rather oldish but I thought "Hey, it's Windows 10 - things might look different!"

     

    Clicking on the information tab produces this:

     

    "F-Secure 16.5


    Common Component Framework 2.76 build 211

    CCF CUIF 10.11 build 134
    CCF DAAS2 1.10 build 646
    CCF Guts2 2.05 build 134
    CCF Upstream 2.02 build 681
    CCF Diagnostics 9.05 build 278


    Copyright (c) 1993-2016 F-Secure Corporation. All rights reserved. [...]"

     

    ...so it seems to be somewhat up-to-date when you look at the copyright "2016" appears so I'm not sure if this is really an old version.

     

    Another question: Is there a foolproof way to *completely* (even in the registry) remove all F-Secure products to make sure the new(er) versions are installed? I will do this if everything else fails but this is quite a big step. I won't be able to test for the next 3 hours as a backup routine is running at the moment preventing me from reboots.

  • UkkoUkko Posts: 3,220 Superuser

    Hello,

     

    Sorry for my reply (maybe you have to get help from F-Secure team).

     

    Your screenshots and small descriptions looks like (for me):

     

    --> System think that there is broken installation (not completed) for F-Secure AV.

    Or you launch it (when trying to open interface).

     

    Because there next points:

     

    -> Launch pad (which triggered) with two pictures (Safe Search and F-Secure Key promo) and F-Secure LOGO as menu trigger;

     

    Usually (on current time and for fresh up-to-dated builds) this is can be visible just with steps before install or during uninstall.

     

    -> Under the global settings you can to get information that F-Secure AV not installed and link-trigger for install it.

    And information that F-Secure IS installed there (maybe you have two desktop-logos of F-Secure or folders. So maybe you able to get anohter F-Secure IS main logo and as result main UI, which can be as under screenshots with both modules installed);

     

    Basically.. you able to re-check "Updates"-tab under the Global settings and re-check which list there.

     

    -> Your information from "About" with build number looks like not completed totally.

     

    Which usually can be before installation (when just main common services installed, but not modules as AV or Browsing Protection); Or during uninstallation.

     

     

    ----

    ----

    What I can to think - that there is can be stuck based on installations; Or maybe random trouble around licenses.

     

    I can to think - that maybe you able to try next steps:

     

    --> Uninstall any of F-Secure (IS or AV ; or both if there) from Windows Control Panel (Uninstall software common steps);

    --> Will use F-Secure Uninstall Tool (else one time) from F-Secure ftp;

    But this will trigger to remove other software by F-Secure too (if installed - Freedome or F-Secure Key);

     

    After this you able to re-check folders under the system (just by search it for "F-Secure" under Explorer);

    But I not sure that you have to remove them - because it can be helpful to do fsdiag (and proper logs can be removed); Probably you able just use two steps: proper uninstall by common steps under the Control Panel (and restart system after that);  Next - will use F-Secure Uninstall Tool and restart too (should ask it).

     

    After this - just try to install from first F-Secure Internet Security with proper subscription for device.

    ---

    ---

     

    About your main troublepoint:  probably there was known troubles with extensions and Firefox; and with re-install process for extensions. Maybe it not work properly on current time.

    And also maybe you able to do this manually (after clean installation - if will be still trouble);

     

    But also... what do you mean about Browsing protection do not work?

    F-Secure extension/addon should be related just with features like:

    --> Show rating pictures for search results under HTTPS Bing/Yahoo/Google  (but for HTTP - you able to get search rating pictures with disabled extension);

    --> More proper handling some of connection points under HTTPS;

     

    But Banking Protection, Blocking malicious web pages should be with work-status - if extension is disabled - anyway;

    If browser is supported; And if F-Secure Browsing Protection module installed;

     

    Sorry for reply else one time.

     

    And for long reply.

     

    Thanks.

  • SimonSimon Posts: 2,661 Superuser

    Just another thought - in your first post you said you had a 'uBlock' add on in Firefox.  Have you tried disabling that?  I just wonder if it might be interfering with the F-Secure plug-in.  It may mean re-installing FS again, but it might be worth investigating.

     

    With regards the Launch Pad, I have a feeling something odd is happening, because I'm pretty sure that hasn't been there for a while now.  The desktop and system tray icons open the UI directly now.

  • SimonSimon Posts: 2,661 Superuser

    Glad you got it sorted, and thanks for coming back to let us know.

     

    I'm not sure if there is a common issue with FSIS 2016 and Windows 10 - often, problems such as this may be caused by conflicts with other security software - that said, I think Windows 10 does 'interfere' too much where it has no business to do so.

     

    I know you've solved this for now, but what you may wish to do is create a Support Ticket, and attach the file from the Support Tool, so that the tech guys can have a look at your system.  They may be able to work out what's causing your repeating problem.

This discussion has been closed.