Subscription not working - anyone can help?

Jaheni Posts: 3 New Member

Hi. I just paid £22.99 for the annual android subscription. But the app keeps saying Could not restore existing subscription,  the app automatically tries to complete this later. The app is not working or activating.
I paid via Google Play  and have reinstalled app but still not working. I wanted to use this app tonight so getting quite frustrated. I haven't been given any code or user id? There are no instructions, rather than the above error message. I'm just about missing the 2 hour return window on Google Play and don't know what to do.   




  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi Jaheni,


    Were you able to restore your subscrition for Freedome? Were you already having any previous android app store subscription/multi device subscription for this device before purchasing the annual license?

  • Jaheni
    Jaheni Posts: 3 New Member

    Hi. No previous subscriptions, I only had the 5 day trial. And it's still not working, I've tried uninstall but nothing seems to help. Please advice what  to do?Screenshot_20161209-054441.png

  • TimStoop
    TimStoop Posts: 2 New Member



    I have exactly the same problem. I had a yearly subscription which I cancelled and it expired today. I decided to renew it after all. The payment was received by Google, but the app give me the same message as described above (but in Dutch). I tried forcefully closing the app and restarting, removing the application and reinstalling it and rebooting my device. Nothing helped, my subscription is still not recognised by the app.


    Any help would be appreciated.

  • Jaheni
    Jaheni Posts: 3 New Member

    Just to let know, I managed to Chat with someone at F-Secure. He said the issue is not theirs, but its an issue with Google Play! So I contacted Google, and they couldnt believe that... they payment had gone through fine. Anyway they arranged a refund, but guess what: the app still has that same error message. There is no option to even try subscribing anymore.


    I have reinistalled the app like 5 times now, and cleared cache, data, folders related to app. Still the same error and no option to re-subscribe.


    I always had respect for F-Secure - but really losing it pretty fast...

  • TimStoop
    TimStoop Posts: 2 New Member

    I had a chat with F-Secure support as well. He did try to help, but there seems to be something wrong in the app or something. We ended up concluding that I better request a refund from Google and buy a license on the F-Secure site itself. Not happy with the experience here, but probably will buy a new license. Once Google has processed the refund.

  • Tapsa
    Tapsa Posts: 82 F-Secure Employee



    We need more information about this. I'll contact both of you separately by private message with further details.




This discussion has been closed.
Product & Pricing Info