FreeDome not connecting to any servers using PC

Hello,

 

For the past 2 or 3 days, I haven't been able to connect to any FreeDome servers on my PC. It just keeps "connecting..." but never moves past that. On mobile (Android) it works just fine using the same WiFi connection, but no chance on PC. Otherwise my WiFi connection is strong and there have never been any problems before this. Please help.

Accepted Answer

Comments

  • Well, looks like I was partially wrong. It does connect after a very long wait, but then I have no internet access anymore. No pages load, I just get an *instant* "No connection" or some other message in my browsers.

    Using Windows 10 btw.
  • Hi,

     

    Did you get a solution for this?

    It seems to be that I am having exactly the same behaviour as you. It takes a long time to connect and when it finally connects, any web page instantly says cannot find server.

    I did nslookup and it seems to be DNS that comes with the TAP interface is not responsive at all.

     

    After the latest upgrade (yesterday) behavior changed a bit, it still takes ages to open the tunnel (but it eventually connects), however it seems to be that no traffic goes into the tunnel.

  • Hi,

     

    Glad to see I'm not the only one experiencing this. No, I haven't got a solution for this yet. Still the same symptoms: connecting for a long time, then not loading any web pages.

  • =)

     

    I thought so too before I checked my location with whatismyip.com.

    It turned out that all my browsing went directly to internet, not into the tunnel.

     

  • anomanom Posts: 1

    Issue could have been related to this:

    https://tech.slashdot.org/story/16/12/10/014231/new-bug-in-windows-10-anniversary-update-brings-wi-fi-disconnects

     

    "Speculation at this point says the disconnect results when a machine performs a fast startup, setting the machine's IP address to 169.x.x.x. It's an old problem, but somehow it's come back in spades in the past two days"

     

    You could check if FreedomeVPNConnection interface has IP starting with 169 when the problem occurs. Full PC restart might solve the issue (not just fast startup). Other possible way to recover might be:

     

    1) Put Freedome in the problematic state (VPN connected but Internet not working)
    2) Open Windows "Network Connections" view.
    3) Right-click on top of "FreedomeVPNConnection" and select "Disable"
    4) Freedome will try to reconnect and it will fail with "netsh.exe failed..." type of error, wait for that.
    5) Again in Windows "Network Connections" view right-click on top of "FreedomeVPNConnection" and select "Enable"
    6) Press VPN on button in Freedome and see if problem got solved.

     

  • Just began to do some debugging and surprise surprise, everything works like a charm =)

     

    The root cause though remains in the dark....but VPN works and works as expected.

     

     

This discussion has been closed.