F Secure when trying to activate after installation get Check Network connection

Tried help line  no help really did not seem to have any answers.

 

Gave up so seeking help here.

 Installed via Google Playstore  on  on tablet/mobile phone ok..

Icon for activation on tablet screen

Log on accepted. Then " check network connection and try again".

 

I did this several times to no avail.

Any help please.

Comments

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Labby,

     

    I managed to find your case opened with our Support team and update them about this Community post. They are checking on the case and will be responding back to you about the further steps.

     

     

  • DJHUKDJHUK Posts: 1

    Any solution to this yet

  • GMACGMAC Posts: 1

    I have just subscribed for a year to F Secure Safe and trying to install on my Samsung Tab A (Android 6).  All accounts were set up straight forward, until I download the android app.  Having moved past the initial screen, I also get the "check your connection and try again" message.   My connection is over 100 mb/so it's not that.  Have also uninstalled and tried again, but to no avail.

     

    Any Ideas?   

  • Hi, did you ever sort this? having the same problem. Thanks 

  • LakshLaksh Posts: 4,440 Community Manager

    Hello Everyone,

     

    I found an article related to the connection issue. Could you please check this article which has some steps outlined?

  • I have just got 1 years subscription for 5 devices. Installed on my laptop with no problem. Then installed on phone (samsung galaxy s7 edge) and every time i try to log in it tells me to check my connection and try again.

     

    I'm connected to my home networks virgin media cable connection. And the same message comes when I'm connected to my 4g network on EE. 

     

    Please advise? I have no problems connecting to the f-secure https test page on both connections. 

  • ive sent several emails and asked for help in other sections to absolute no response at all, its like you guys have no after sales support what so ever..

     

    anyway, i have 1 year subscription with 5 licenses, i activated 1 licece for safe on my laptop (windows 7) then i tried to use another on my samsung galaxy s7 edge, every time i try to log in it tells me to check my connection, i have tried 5 different wifi networks and 2 different mobile carriers 4g connections, and it will always tell me to check myconnection. 

     

    hopefully ill get some support on here so far im extremely dissapointed with this comapny

  • seriously? no reply at all.. all i see on  the play store is 1 star reviews with people with this exact same problem.. its like there isnt nothing there to connect too.. it has nothing to do with our connections.. f-secure are not giving me any support what so ever on this.. really awfull aftersales support.. ive emailed 3 times and posted here but not a single message or response 

     

    please advise.

  • SimonSimon Posts: 2,633 Superuser

    Did you check the article linked to above?

     

    https://community.f-secure.com/t5/F-Secure-SAFE/I-am-unable-to-connect-to-the/ta-p/15794

     

     

    This issue does seem to be related to Samsung phones.  Maybe they have something in their software which is causing this?  If you've not already done so, I suggest you send in a Support Ticket, and hopefully you will get a response.  

  • Yes i read all that. Is absolutely nothing wrong with my connection or time settings. I've open several tickets just like all the other people from the play store. No response

  • Its 100% An account issue. As I've tried creating a new account and the new one has no trouble connecting and signs in right away with 30 day free trial.

     

    But every time i try logging in with my 1 years subscription account it tells me to check my connection. Yet it works just fine with a trial credentials. I change absolutely nothing to my network settings. It lies to me. There is nothing  wrong with network connection. This proves that. Its an issue on f-secure end to do with my account. And they refuse to even reply to me let alone fix it. Not impressed with this company so far. Very disappointed.

  • LakshLaksh Posts: 4,440 Community Manager

    Hi @Marty3,

     

    Could you please share with me in a private message the case number so that I can check further for you?

     

  • Tell me where to find case number. I'm not sure what you mean

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Marty3,

     

    Since you mentioned you have emailed, please provide me the case number you got from our support (it would be in the subject if they have responded via email). In case you have not got in touch with our support, I would recommend to either chat with them or call them directly in order to troubleshoot further on your issue.

     

This discussion has been closed.