Purchased subscription for Freedome but code does not work.

Some time ago I used the 30 day trial subscription for Freedome. I now purchased a 12 month subscription and went to the Subscription tab, clicked Have a code? and entered the code I had received. I then get an error message saying "Could not verify your code. Please try again later."

 

I have a Mac and this is the only device I've tried Freedome on. I'm sorry if the solution for this problem has been discussed before, but I could not find a response that helped me on the forum.

Best Answer

  • KlaraKlara Posts: 3
    Accepted Answer

    Just reinstalling (replacing) Freedome did not work. But after writing this message I also tried uninstalling my current Freedome installation and reinstalling fresh. This helped! Perhaps there was some licensing information from my expired trial license in the old installation that was the problem?

Answers

  • LakshLaksh Posts: 4,424

    Hi Klara,

     

    Glad to know your issue is now resolved. We do have an article related to your error message.

     

    In your case, I am unable to tell the exact reason of why it happened. May be you were using an older version of Freedome during the trial period which caused this issue. So, uninstalling and reinstalling resolved this issue.

  • KlaraKlara Posts: 3
    Thanks for your reply! Yes I read that article but could not see that any of the scenarios were applicable to me. Plus I couldn't find my way to the solution from that article (or other discussions). Perhaps it is a language problem in there, but all is ok now, problem solved :)
  • LakshLaksh Posts: 4,424

    Good to know all is well, Klara! Thanks for updating us.

This discussion has been closed.