Subscription has expired on mobile device - butI have paid for an annual subscription

I bought a multi-platform Freedome subscription a few weeks back. On my Mac the software works fine and according to the "Subscription" tab it is active until Oct 2017. However, on my iPhone, the subscription has suddenly expired.

 

Message: "EXPIRED Your subscription has expired. To renew your subscription, please contact Total".

 

When I click the option "Did you already buy a multi-platform subscription?" on the phone, and enter the Freedome account ID, I get the error message "Oops You have already used this ID on this device". When I try the next option:  to log in via the phone, I get the message "Subscription has expired. Renew your subscription to finish the installation". The third option on this screen, "Restore purchase", doesn't make anty difference either.

 

What might be the problem?

 

Many thanks.

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi KarinEnskog,

     

    I am guessing that the Freedome which is installed on your phone might be from Total as seen in this article. If not, was Freedome installed using any other code before or from the app store?

  • I think you might be right! I believe I initially installed the app as a free trial and perhaps the provider was Total. So, following this logic, I uninstalled the app and downloaded it again from the App Store using the link provided in the post that you reference - and noting that the provider was F-Secure.

     

    However, when I now go through the motions described in my initial post, I still get the message that the subscription has expired and when I input the code I'm told: 'Oops. You have already used the ID on this device'. I tried the 'Restore Purchases' link this time too and the same thing happened as with the previous version of the app.

     

    I have only ever used the code that I got from F-Secure when I bought the licence.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi KarinEnskog,

     

    May I know how many devices are currently using the Freedome code apart from the iOS device? Have you, by any chance, used up all your available Freedome licenses (even reinstalling using the same license)? If you have any other device apart from the iPhone, I would recommend to uninstall and reinstall using this code to inititate the license transfer for your code. This article has more details about the license transfer function in Freedome.

     

    Please try to download a new version of Freedome from this link for your iPhone and retry the installation after the license transfer is initiated.

  • Hi there,

     

    Thank you very much for your suggestions.

     

    In response to your question, Freedome is only installed on my iPhone and on my laptop (Mac OS).

     

    I have reinstalled the app using the link you provided, but no luck with that: it sent me down the same loop that I have described earlier.

     

    Re the transfer option, from the article you linked me to:

    "Each Freedome installation uses up one of the available licenses from your multi-device subscription. Uninstalling Freedome does not release the license from the device. This means that uninstalling and reinstalling Freedome on the same device will result in another license being consumed."

     

    I'm guessing that this means that I should try uninstalling and reinstalling the software on my Mac. However, I am worried about doing this since I'm currently working from Ethiopia where internet access is limited and VPN installations are sometimes blocked. Is there some other way to go about this...?

     

    Many thanks

    Karin

     

     

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Karin,

     

    In order to do the license transfer, it has to be done on a Windows/Mac/Android device. Freedome does not have the license transfer option in iOS yet.

     

    If you have any other device apart from the Mac, you can try to inititate the license transfer by reinstalling Freedome and uninstall it later so that the license transfer can be initiated in your iPhone also.

  • Aaaah - this is sending me mad! Just installed an reinstalled Freedome four times on another device until I was able to initiate the Transfer. I was informed that the licence was transferred successfully. I then removed Freedome from the iPhone and reinstalled it. Upon entering the code, I got exactly the same message as before: "Ooops - You have already used this ID on this device."

     

    There must be some data left on the phone even though I uninstalled the software? Am I doing this the incorrect way? I'm clicking on the x in the corner of the app icon, and am told  that this will remove the app plus all its data. So I go ahead. I then connect the phone to the computer, to which I have downloaded the app (can't connect to the app store using the phone without vpn), and copy the app across to the phone via iTunes.

     

    What to do? I'm unable to use social media and unable to access sites using my phone...

  • rdmrdm Posts: 5

     I have exactly the same problem as the original poster. So this problem is not unique to her, and I sympathise. This really needs some attention from technical support. 

    KarinEnskog
  • LakshLaksh Posts: 4,444 Community Manager

    Hi @KarinEnskog and @rdm,

     

    If the same error message persists, kindly get in touch with our Support team via chat or phone to troubleshoot this. They will check on the license details of Freedome to advise further.

This discussion has been closed.