Fatal Error

Petu Posts: 1 New Member


I updated my Freedome and it started complaining  about a fatal error. I contacted support and I was adviced  to unistall my Freedome and try installing it again. The problem now is that when I try logging in with my subscription code it won't accept it. The computer is still the same one I downloaded the program to the first time and the subsription I paid for is meant to be usable for 1 year.

What can be done about this?

Thank you for all your help in advance. 



The whole problem got solved by choosing Transfer when the code didn't work. Sorry for the bother!


  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Petu,


    Thanks for keeping us updated on your progress. I am glad to know that your issue is now resolved.


    As mentioned in this article, we have the license transfer functionality with Freedome. You can go through the article for more information.

This discussion has been closed.
Product & Pricing Info