F-secure renders computer unresponsive

Hello,

Would just like to share today's F-secure experience:

 

I started my computer (Windows 7 x64 with F-Secure) and I basically could not use any application:

  • OneDrive was trying to synchronize even though there was nothing to do
  • Word & Outlook would not open
  • Firefox stopped responding
  • VirtualBox crashed
  • Windows Notification Center shows “F-Secure” as not working and invited me to activate it

When I switched off “Virus Protection” and “Deep Guard”, everything worked again.

So I checked the for possible updates, yet F-Secure showed me that all updates are installed successfully:

 

Though when looking into the update log it showed me that the latest “Aquarius” update was not installed.

Well, there is no button to install an update manually. Eventually I had to “brute force” switch of the computer because I could not get to the Windows Restart button anymore, or the task manager, or a command line to restart gracefully.

 

Following the restart, it seems now that the update has been installed and F-Secure works again and applications are responsive now – however, I would really appreciate if this experience could be shared this with your technical and/or development team because the whole incident made me loose 1.5 hours before I could actually work L. That is really not the level of service & functionality that I expect for a paid subscription.

 

In addition, I find it very unsatisfactory that one can raise a support request if one is a corporate customer but not as an individual. I believe that my private time is just as valuable than any other persons, working or not, so having a working support in the time slots where people work privately (weekends) would be nice! /*Edit: Looks like there is a support ticket for indiviuals... you just have to search through the forums to find it... very convenient*/

Answers

  • SimonSimon Posts: 2,571

    @ak05 wrote:
    In addition, I find it very unsatisfactory that one can raise a support request if one is a corporate customer but not as an individual. I believe that my private time is just as valuable than any other persons, working or not, so having a working support in the time slots where people work privately (weekends) would be nice! /*Edit: Looks like there is a support ticket for indiviuals... you just have to search through the forums to find it... very convenient*/

     

    With regards support requests for Home customers, this is available in a link at the bottom of the Home Products main page, so, with respect, it's not actually that difficult to find:

     

    https://www.f-secure.com/en_GB/web/home_gb/home

     


    @ak05 wrote:

    Hello,

    Would just like to share today's F-secure experience:

     

    I started my computer (Windows 7 x64 with F-Secure) and I basically could not use any application:

    • OneDrive was trying to synchronize even though there was nothing to do
    • Word & Outlook would not open
    • Firefox stopped responding
    • VirtualBox crashed
    • Windows Notification Center shows “F-Secure” as not working and invited me to activate it

    When I switched off “Virus Protection” and “Deep Guard”, everything worked again.

    So I checked the for possible updates, yet F-Secure showed me that all updates are installed successfully:

     

    Though when looking into the update log it showed me that the latest “Aquarius” update was not installed.

    Well, there is no button to install an update manually. Eventually I had to “brute force” switch of the computer because I could not get to the Windows Restart button anymore, or the task manager, or a command line to restart gracefully.

     

    Following the restart, it seems now that the update has been installed and F-Secure works again and applications are responsive now – however, I would really appreciate if this experience could be shared this with your technical and/or development team because the whole incident made me loose 1.5 hours before I could actually work L. That is really not the level of service & functionality that I expect for a paid subscription.


    I have also experienced some sluggishness when starting my computer if F-Secure is applying / installing updates, and like yourself, things have ground to a halt on one or two occasions.  Instead of trying to reboot, though, I just went and got a coffee and allowed the PC time to process things, and within a few minutes, everything was back up and running as normal.  I say "a few minutes" - this could be up to 10-15 minutes, but nothing like the 1½ hours which you experienced.  When you check the list of updates and it says something like, "Aquarius update was not installed", this usually means that the update is still downloading, or has downloaded and is still installing.  I don't think there's anything you can do to manually speed up this process.

     

    Hope that helps a bit!  :)

     

  • ak05ak05 Posts: 5
    Thank you for the link @Simon, but I am not sure where you get the support request form? I get:
    - knowledgebase
    - call us
    - chat with us
    and at the bottom some instructions to create a diagfile. Given that f-secure rendered the computer completely unresponsive that would not have worked. So I rest my case... it is very well hidden and not the same level of service as for a corporate customer.
  • SimonSimon Posts: 2,571

    Not sure if you're in the UK.  If not, you may be seeing something different, but I definitely get a link to Contact Support, which takes you to the support ticket link.  

  • UkkoUkko Posts: 2,933

    Hello,

     

    Maybe there changes under web-page.

    I also do not able find proper-valid URL from main page (for home users).

    But there is still possible to get direct URL from business-pages for support -request (differently with home users).

     

    And with this knowledge... available this URL for Home users:

    https://www.f-secure.com/en/web/home_global/support/support-request

     

    Which previously was visible under Home Users pages too.

     

     

    Spoiler

    Also about your experience with system-stuck. Maybe I have experience around something like this (two times). Usually it was briefly/after Scanner Manager Update and restart for system. Next restart fix the situation.

    And system was with view - like if not available to launch browser, opening task manager... or allow UAC prompt (and some of other things). Not sure about reasons... maybe something prevented to proper start under system (based on time-out or other).

     But anyway... not sure that there is can be related-reasons with your situation.

     

     

     

    Sorry for my reply.

  • ak05ak05 Posts: 5
    Thx @Simon for the note. Yes I did not think at all about different pages rendered from different countries. That might be indeed the problem ;-).
  • ak05ak05 Posts: 5
    Thx Ukko for sharing the link and your experience on this topic. Well, now I have the link should something happen again ;-).
    And let's hope things won't get stuck next time for so long.
    Cheers & stay happy!
  • VilleVille Posts: 478

    Hi @ak05

     

    Even though the problem has been solved, you could still open a support ticket, attach support tool output (fsdiag.7z) and ask them to forward the fsdiag to us in R&D, so that we could take a look if we can figure out what caused this issue.

     

    Ville

    (F-Secure R&D)

     

  • ak05ak05 Posts: 5

    Hello @Ville

    Thank you very much for your suggestion. Next time I will do that - this time it will not be of much use anymore so late after the event.

    Best & thx.

This discussion has been closed.