F-secure's SAFE Firefox extension can not be installed on MAC

After successfully having installed F-secure SAFE  on a Mac, the brouwser extension for firefox  won't install properly. after I ran "install brouwser extension for firefox" I can see that it is 'checked green' as being properly installed but after restarting firefox it shows orange again as being "not installed or turned off in firefox". checking on the add-on page shows there is no f-secure item at all which I could possibly "allow for installation" to get the extension going..

Tried all the recommended procedures (uninstalling, installing, restarts etc.) numerous times and searched databases here in vein for a possible solution of this problem.

 

I appreciate any help on the issue.

thanks in advance.

 

in safari the installation of the brouwser extension was no problem, works like a charm.

 

F-secure Safe Version 16.2 (15839)

MAC OSX 10.11.6

Firefox 49.0.2

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi sutzke,

     

    Have you tried all the steps mentioned in this article for installing the Firefox extension on your Mac?

  • hallo laksh,

     

    yes, I've done all that.

    exept for step 6, that couldn't be completed, because after restarting firefox there simply seems to be NO F-secure add-on added to the Add-on page that could be "allowed for installation".

    do you have any idea how to proceed with this?

    how do I get this F-secure extension working in firefox, when the initial installation of F-secure SAFE fails to implement that extension properly?

     

    ((:

     

    thanks in advance for any further feedback.

     

  • ps: I was thinking... could it be possibly an incompatibility with other add-ons I have installed in firefox? for example with another web-security add-on such as  "NoScript Security Suite"? anything known about that?

  • LakshLaksh Posts: 4,444 Community Manager

    Hi sutzke,

     

    I am not completely sure if there would be any incompatibility with the other add-ons. I see the version of SAFE and Firefox are recent and the issue persists even after following the above shared KB article. I would suggest to get in touch with our Support team via chat so that they can troubleshoot further.

This discussion has been closed.