Impossible to connect Freedome

Hello,

 

I just bought a 1 year subscription to Freedome. It'w working on my Iphone and my Ipad, but when I try on my Mac it's connecting, and after 30 sec trying to connect it just tells my that it's not working anymore.

 

What should I do ?

 

Thank you

Best Answer

Comments

  • LakshLaksh Posts: 4,439 Community Manager

    Hi CorentinB49,

     

    May I know if you are having this issue with different locations as well? Which location are you using currently? What is the exact error message you see?

     

  • Hello,

    I tried different locations and I still have the problem.
    This is not really a message error I think, it's just the basic message when you put it on OFF.
    Something like "freedome is not anymore encrypting your data and not protecting etc.."
    I don't have access to my computer right now that's why it's approximative sorry.

    Thank you
  • Hello,

    I used the trial version some months ago and it worked perfectly. Then I bought it for 1 year and it's not working anymore. I upgraded the version but I didn't try to uninstall it.
    I will try tonight
    Thank you
This discussion has been closed.