F-Secure on 100% disk for hours after Windows updates


This is the second time after a Windows cumulative update that I got into severe problems. F-Secure AT LEAST  is part of that problem. This time it was on a package of Windows updates including cumulative KB3194798.

Currently I am looking at a 100% disk use by F-Secure immediately after starting up my PC. I have spent the WHOLE yesterday on fixing similar problems and getting my 2 PC's to normal use again. It is NOT a scheduled scan.

This just stopped after 10 minutes or so. Maybe only because I tried switching F-Secure off. But that certainly does not respond  quickly, if at all.

The first time this occurred was on  previous cumulative Windows update KB3194496. It went on the WHOLE NIGHT before I killed it. And it kept on reoccurring  after restart of my PC. I got on removing F-SEcure, reinstalling it, trying all sort of things. Switching off does not seem to work. Killing processes only results in MORE processes.

This is RIDICULOUS. I am very worried for the next Windows update. I consider replacing F-Secure by a different protection program. And/or applying the cumulative update incrementally, if possible.

What is going on F-Secure?!

Can you fix this? This is not workable.


  • Simon
    Simon Posts: 2,667 Superuser

    Have you sent in a Support Ticket, attaching an FSDIAG from the Support Tool?  I've recently had not dissimilar problems myself, following Windows Updates, but these issues were with FS Protection (beta), on Windows 10.  The problems were resolved in my case by a full removal of FS, using the F-Secure Uninstallation Tool, followed by a fresh install, but this did coincide with a program update so I'm still not really sure if it was FS or Windows causing the issues, but I suspect a combination of both.

  • Ukko
    Ukko Posts: 3,634 Superuser



    With Windows 10 updates I also feel too much resource-usage at the time... when system updates downloading/installing (I think ...maybe partly because... F-Secure can to scan this "traffic/activities" and create small delay or take more resources), but mainly.. I think that there is just system "trouble" with too much usage resources under updating. And system goes to be too much under "network and system overload" (based on my experience), when not really possible to do something else.. with no visible result about slowness/delays/hot-increasing.


    And about disk usage after starting up: but does this possible.. that during this load/start/launch system... F-Secure just goes to download/install updates databases (?!). This is most likely if system not often loaded. Or if there was pause between previous install-actions.

    Usually F-Secure installation have delay to trigger downloading/installing updates at launch. But time to time.. can be situations.. when this is triggered with practically same time of system "main" loading.

    when F-Secure download/install it (and if there updates for largest signature-engine: Aquarius ; or when there some updates else) ... usually disk usage will be probably "full" and "hardest". If there anything else, which can to create load/use system resources.... there will be more visible.


    Sorry for my reply.


This discussion has been closed.
Pricing & Product Info