F-Secure blocks webpages and emails

I have noticed that F-Secure blocks certain web pages. I recently couldn’t access the Yahoo web page to view my emails. All I could see was some... sentences and words. The following day I retried and the Yahoo webpage did appear but it does not cover the whole screen as it did some days before and some information is not shown. I have to use my ipad to have a better view of my Yahoo account.

Also when I receive emails containing pictures or logos those pictures are not shown. This problem appeared after F-Secure was upgraded a few days ago. 

I have windows 10 home edition and TalkTalk SuperSsafe Boost 16,3

Best Answer

  • bibliobiblio Posts: 9
    Accepted Answer

    Thanks Simon. It seems that is not F-Secure that blocks the website. Probably is some web browser settings that need to be configured.

Answers

  • SimonSimon Posts: 2,583

    Have you tried temporarily disabling the protection in F-Secure, to check that it is definately that which is blocking web content?  Usually, it would only block something it sees as malicious.  Is this just with Yahoo pages and emails, or does it affect other domains as well?  I know they have been in the news today in relation to a huge data theft dating back to 2014, so I don't know if that could be anything to do with your issues.

  • Could you please tell how I can temporarily disable F-Secure. Thanks for helping me.

  • SimonSimon Posts: 2,583

    Open the UI, either from the desktop icon, or the icon by your clock.  Click Tools, then you'll see a button to 'Turn off all security features'.  It may be slightly different in yours, as this is the beta version.

     

This discussion has been closed.