Freedome not connecting via my network

Hi!

I've tried talking to F-Secures support regarding this issue, but they seem like they either don't want to help or don't know anything, so I thought I'd try this channel instead.

 

So, I am unable to connect to Freedome over my home Wifi network (I've tried a couple of computers and the Android app). It is stuck in connecting. One night when I left the computer on, it did connect to the UK, but the connection was very slow and when I tried another location, it was stuck on "connecting" again.

 

I have the following setup:

I have a 4g connection (Sonera Liikkuva Netti in Finland). The sim card is inside a Huawei B593 4g router and that is hooked up to Linksys EA6900 AC1900 Smart Wi-Fi Dual-Band Router.

 

I have tried connecting straight to the Huawei as well, however the issue is the same.

I have tried the wifi network at work and there Freedome works fine.
And of course I've tried to restart everything.

 

Any thoughts or ideas that might help me connect using Freedome are more than welcome! Thank you in advance!

 

 

** Edit: The work around found here: https://community.f-secure.com/t5/F-Secure/Freedom-can-establish-connection/td-p/81321
does not work for me

Comments

This discussion has been closed.