I can not make connectionany

molenster Posts: 1 New Member

When Freedome is turned on no internet connection works anymore.

I use Firefox and every site is blocked.

I use Mailwasher and every incomming email is blocked, a.s.o.


I use Windows 10, aniversery update , on a Samsung laptop Intel Core I5 6Gb RAM x64 processor


What can I do apart from swichting Freedome off.



  • botibot46
    botibot46 Posts: 1 New Member

    I also have the problem, that freedome won`t create a working connection. It tries to establish the connection. During this time the internet is down. Finally it stopps and says "F-Secure is not protecting anymore". I also have Win 10 with the latest update. It`s a new phenomenon. It used to work properly.


    Can anyone give a solution?

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi molenster,


    What message do you see in your browser when you try to connect to a website? Have you tried to connect to a different location and see if it works?


    What is the version of Freedome you are using? Have you tried to uninstall and reinstall Freedome to see if the issue resolves?

This discussion has been closed.
Product & Pricing Info