Intermittent Disconnects

I'm having an issue on Windows 10 losing internet connectivity while using Freedome. If I'm connected to the internet and enable Freedome, things will work fine for a while (usually from 10 minutes to an hour or two). After this initial period, pages will stop loading and my browser tells me I'm not connected to the internet. If I turn Freedome protection OFF, things work (without VPN). If I then turn Freedome back ON, things will work again. Basically, I need to 'power-cycle' Freedome every 10-120 minutes or so. What could be causing this? Is there anything that can be done to troubleshoot?



  • I am having this exact issue as well. W10 anniversary edition using Canadian servers.
  • Ben
    Ben Posts: 2,641 F-Secure Product Expert



    @electricpear are you seeing this behavior on a specific location or all locations.


    Which versions are you both using?

  • I haven't tried other locations, now that you mention it. I've been connecting to United States, Southeast. I'll try switching locations to see if there's any difference. 


    My version is 1.6.3289.0.

  • Still intermittently disconnects from other selected locations as well. 

  • I am using 1.6.3289.0 as well.
  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Could you please take contact with our support so we can investigate better these disconnections.

  • Vetraci
    Vetraci Posts: 156 Adventurer
    Same problems here for the last 2-3 weeks. Experiencing connection problems on different devices (iOS, Windows 10 Pro) and locations.

    Sometimes it seems Freedome loses connection and cant reconnect. As long als Freedome tries to connect then there is no traffic (Browsing, downloading) possible. Turn around for this issue is to manually open the Freedome app and turn it off and on again.
  • I did contact support (ticket #XXXXXXXX), but no one has responded in three days. Not very good customer service, frankly. 


    EDIT: Remove PII

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    @electricpear thank you for your feedback.

    I highlighted your ticket to our support. 


  • I still haven't heard anything. I'm beginning to think I should just ask for a refund.
  • I am looking at other VPNs to use now, because this issue makes it unusable.
  • Did anyone have any luck resolving this issue?
  • I've had the same problem for awhile. Tried to connect to Finland, UK, US among others and it's definitely not related to the location.


    Windows 10, latest Freedome update etc. Previously there have been guides to do all kinds of tricks to refresh drivers, do dnsflushes, rename the TAP-driver... Nothing has helped to resolve this problem permanently.


    I never really got any response from the customer service. Thinking about cancelling my subscription as this is not what I paid for.

This discussion has been closed.
Product & Pricing Info