F-secure blocking java?

Hello, I'm running an IP Camera via Internet explorer and it uses Java (D-Link DCS-5020L in local network). The window is blank, unless I disable all security features of F-Secure which makes the camera feed visible!

 

I'm running Windows 10, F-Secure version 16.3, latest Java.

 

Thanks.

Best Answer

Comments

  • SimonSimon Posts: 2,642 Superuser

    Hi,

     

    Sorry if this is a wild goose chase, but have you looked in your Application Permissions in the Deepguard settings, to see if anything has been blocked?  I don't think you can manually add permissions there, but you can remove blocked applications.  Alternatively, could it be a Firewall setting? 

     

    There is also the facility to Submit a URL or File to the F-Secure labs for analysis, but I'm not sure if that would be any use for this.

     

    Hopefully someone more technical than myself may be able to help further, but if you don't get any responses here, then I would suggest raising Support Ticket so that the tech guys can look into the issue for you.

    Ukko
  • lefmanlefman Posts: 5

    Thanks for your reply.

    I've checked deepguard indeed and the only application there is teamviewer. Even if I disable firewall or web protection the problem persists. When I disable F-Secure totally it's solved.

    To access my ip camera you have to go to a certain address http://192.168.1.xxx where you can view image feed via Java. Maybe it blocks non https sites? I don't know what to submit.

  • SimonSimon Posts: 2,642 Superuser
    I do know that F-Secure checks new networks, and that address looks like a router IP, so that may be something to do with the problem. Unfortunately, I've no idea how you can see / add / amend the allowed networks in FS, but the support guys may be able to help.
  • UkkoUkko Posts: 3,180 Superuser

    Hello,

     

    Sorry for my reply/suggestions.

     

     

    Spoiler

    There ( https://community.f-secure.com/t5/F-Secure-SAFE/Why-did-F-SECURE-SAFE-start-to/m-p/85927/highlight/true#M15277 ) you created words.. that you maybe have same experience.

    But I think there can be different troubles.

     

    Under "another topic" was most likely situation.. that some "resources" (or certain URLs) blocked by Browsing Protection. And adding them (or full domain) for allowed-list was helpful (as all resources from domain will be allowing to open).

     

    If with your situation can be helpful step with "turn off all security features" (I think - you mean feature under Main UI as "specific" button?) - so maybe your situation can be based on DeepGuard (as example for full design or just about some of files).

     

    I think that there can be most helpful just Support ticket for F-Secure. And they can to investigate situation (for improve it or get normal reason/explanation).

    But between your (action for create ticket) and their response..... maybe you able to re-check some points like:

     

    --> What will be if you open F-Secure Main UI-- Main Settings (as button) -- tab about DeepGuard.

    And there check option, which can be called as "Compatibility mode".

    And re-check situation - how it will be (work or not).

     

    --> If "Compatibility mode" do not create something, which create "workaround".

    So.. maybe will try to disable just this "DeepGuard" module (this is partly more nice, than disabled all security features).

     

    If it will be helpful - so... maybe this is just DeepGuard-based trouble (this is something like HIPS/NHIPS layer of protection). And there of course... most helpful will be ticket for F-Secure Support.

     

    Also.. if it will be related with DeepGuard (or not) - and if you have files under your system (related with application, which you Launch... if there can be any software with design of; not really friendly with IP Camera design Smiley Sad so not sure.. what can be there). Maybe you able to try to exclude this from scanning (possible to do this.. under Main Settings and tabs about Real-time scanning with option to Exclusion list for files/folder or extensions).

     

    If nothing of this not a workaround. So... maybe there have some else options (like under Firewall tab).

     

    Sorry for my reply/suggestion.

     Thanks.

     

    ------

    ------

    Today I also decided to re-check and search web about query for (IP Camera and F-Secure)... and there have some notes based on same (or around same) troubles.

    With one of them.. have point that there indeed can be related option about "Advanced Network Protection" (this is option under main UI settings and Firewall-tab). There was about solution, where in use additional technologies over the browser. But main point can be that there is "streaming". And maybe stream-video blocked by this option. You able to re-check it too (if DeepGuard not related there).

  • I've tried disabling deepguard but nothing happens (java streaming is still blocked). I've also tried disabling windows firewall (I have no f-secure firewall) and java is still blocked. Only if I disable the entire F-secure protection is works.

     

    Any other security feature I can try disabling?

  • Bravo mate! In the bottom of the firewall tab if I unclick "Do not allow applications to download harmful files" it works just fine! I with I could allow the specific streaming and not have to disable the entire feature.

    Ukko
  • UkkoUkko Posts: 3,180 Superuser

    Hello,

     

    Good that this is can be helpful.

     

    But I also think that maybe you able to create Support Ticket for F-Secure (at was suggested by first reply under this topic) anyway. Just with additional information (about which certain feature a reason for trouble and background for IP Camera solution) - maybe F-Secure able to improve (if this is based on this side).

     

    Or/and to inform company (which provided IP Camera / streaming) - if this trouble based on their side (or they can to do something; or just will be known for them).

    lefman
This discussion has been closed.