Freedome VPN: Error on iPad - Subscription expired when in fact it has not

TBone42 Posts: 2 New Member

I bought a multi device version for five devices which is valid until March 15th, 2017. Though i did not buy it on the App store, but as a physical version with the code in it, i used two iPads with the same Apple ID, and both of them worked perfectly until yesterday.


Not having changed anything, today i'm told on iPad #1 "Subscription expired". I had a complete reset of that iPad about two weeks ago - can the problem be a result of that? But as i said: It was still working perfectly yesterday.


I tried everything i found in the community, including de- and re-installing, but nothing makes it work again. And when i try to restore purchases, the iPad tells me that this was successfully done, but it's not.


What can i do now? The box with code etc. is about 950 km away from me...


  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi and welcome here, TBone42!


    Based on your post above, I see you might be using an app store license on your iPad. Since you have used the option 'Restore license', this happens only when you use an app store license and restore your license from there. You can find a similar information about how to use your app store license in your other iOS devices, from this link.

    This article provides more information about how to activate your multi platform subscription for Freedome.


    Have you made any app store Freedome license purchase before on your iPads?



  • TBone42
    TBone42 Posts: 2 New Member

    Hi Laksh!


    Thank you for your very warm welcome.


    As i wrote before, i did NOT buy the license on the App Store and i never did that before. I really can't understand why it suddenly stopped working on one of the two iPads after all was fine for about half a year (multi device license for five devices ends on March 15th, 2017). I suppose the only logical conclusion is the fact that i had to completely reset the iPad that is now facing those problems.


    Is there any way to revive it without having the code at hand?

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi TBone42,


    You need the subscription code in order to validate Freedome. If you get hold of the code from the box, you can try to use the code in the product and validate it.

This discussion has been closed.
Product & Pricing Info