F-Secure Internet Security Banking Protection



since the last update for Internet Security a few weeks ago, banking protetction doesn't work properly.

First of all there's no pop up anymore so I cant't see if the protection is on or not.

But banking protection seems to work somehow when I'm visiting a banking site because it's blocking some sites even when I've already left the banking site.

In earlier versions it was possible to turn banking protection on and off, which helped with such problems, it would be nice to have this option again.

So is there a solution available?




  • SimonSimon Posts: 2,653 Superuser

    As far as I am aware, you should still have the option to turn Banking Protection on and off.  It should be under Browsing Protection > Settings > Banking Protection:




    If you don't have that option, have you tried reinstalling the Browser Extention?

  • dkdk Posts: 11

    Hi Simon,


    thanks for your answer. Well, I don't have the option anymore:




    And I'm using Firefox, so it's not possible to uninstall Browsing Protection. I think I will have to uninstall the whole F-Secure stuff and then reinstall again. But I don't want to and it's not the first time I have problems after an update.

  • SimonSimon Posts: 2,653 Superuser
    You're not on the right page. You need to go to the Browsing Protection module, which I think you should see the link to along the bottom of the main screen, when you first open F-Secure, then click Settings and you should see the Banking Protection options.
  • dkdk Posts: 11

    Thanks for your answer Simon.

    Problem is solved, a new installation was necessary and finally the Browsing Protection Module is back again.

    Like I said before, F-Secure should work on the update process, it's not the first time I had to reinstall Internet Security after a product update.

  • SimonSimon Posts: 2,653 Superuser
    In their defence, sometimes peculiar things happen on individual devices. There's not a lot they can do about that. This doesn't appear to have been a too common issue, as I think we would have had more posts on here if it was. I've been using the Beta versions and I've not had the issue, so it may just have been an oddity with your machine. :)
This discussion has been closed.