Compatibility with Hyper-v in Windows 10 Anniversary Update 1607

F-secure Safe blocks hyper-v virtual machines from starting in Windows 10 Anniversary Update (via the local hyper-v feature built into Windows 10) unless you enable deepguard compatibility mode (i.e. decrease the level of system security). 


Please could you fix this to make F-secure Safe compatible with  Windows 10 Anniversary Update.



  • zeph
    zeph Posts: 2 New Member

    Same here with F-Secure Internet Security and Windows 10 1607.
    When I start a VM (Hyper-V) with disabled deepguard compatibility mode, the wmwp.exe run constant with 12% CPU usage, but the VM will never leave the status "Starting".
    After 2 hours of using 12% CPU, I kill the process ... (Currently my solution to use F-Secure without deepguard compatibility mode).

    With deepguard compatibility mode enabled the VM start immediately.
    (DeepGuard 5.0 build 593)

    Before Windows 10 1607, Hyper-V works fine with disabled deepguard compatibility mode.
    Please fix this issue.

  • Peter
    Peter Posts: 68 F-Secure Product Expert



    I found some information in our R&D ticketing system with a possible workaround.


    We can confirm that there is some form of compatibility problem with Hyper-V on the Windows 10 Anniversary Update, but it is not necessary to disable DeepGuard to avoid the problem. A safer option is to just add an AV exclusion for the C:\Windows\System32\vmwp.exe file. At least for me that solves the problem. 


  • Zoki
    Zoki Posts: 1 New Member

    I had same problem with f-secure in hyper-v . After starting virtual machine , just showing starting and nothing happens. After disabling DeepGuard virtual machines are normally starting.


    Best regards

  • nomadl
    nomadl Posts: 1 New Member

    F-secure have still not solved this compatibility issue months after the Windows 10 Anniversary release.  The only help I have had from them is 're-install f-secure safe'.  Not what I expected to hear.  It would seem like they are either not willing to or unable to solve this issue like some of their competitors have.

  • Peter
    Peter Posts: 68 F-Secure Product Expert

    Hi Nomadl,


    Thank you for engaging us here.  While the underlying issue is still not resolved, the exclusion sould solve the issue when using (also) F-secure Safe. You can find instructions for how to configure the exclusion for real-time protection here.

    And to recap, the file to exlude is C:\Windows\System32\vmwp.exe

    Let us know, if the workaround fails here.

  • gothge
    gothge Posts: 1 New Member

    I have still the same problem. is this fixed?

  • zeph
    zeph Posts: 2 New Member
    Since I exclude the C:\Windows\System32\vmwp.exe in the Deep Guard I have no problem.
This discussion has been closed.
Pricing & Product Info