Cannot connect to internet when Freedome is on

I recently bought Freedome for a year. In the beginnibng it worked fine, but now I loose the internet connection every time I put Freedome on. I use my laptop at home where I have a 4G connection which has  not been causing any other problems.

Please, give me practical advice what to do!
Otherwise Freedome is useless to me and has only been a waste of money.

 

If I need to reinstall Freedome, tell me how to do it and how to get the codes or passpords or whatever is needed. I'm definitely not going to pay another 50 euros for reinstalling.

Comments

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Exmaxi,

     

    May I know if there is an issue in the connection only when connecting to a certain location or with the other locations as well?

     

    Do you see any error message as well regarding this issue?

     

  • ExmaxiExmaxi Posts: 3

    This is an overall problem i.e. I can't connect to any location at all.
    No error messages so far.

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Exmaxi,

     

    Just to confirm, does the Freedome main page show that it is connected and ON? Or does it show OFF?

     

    Regarding your query about uninstalling and reinstalling, you can refer to this and this link for uninstalling Freedome from Win7/8 or Win 10 respectively. And refer to this link for reinstalling Freedome. If you are still having the same issue, you may also contact our support team using the support request.

  • ExmaxiExmaxi Posts: 3

    Freedom main page shows ON during the problem

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Exmaxi,

     

    Since Freedome is seen to be turned on, which means, it can connect to a location and the VPN is established. However, do you see any error message when accessing the internet? Like, is there any error seen in the browser if you try to open a webpage?

This discussion has been closed.