[Solved] No internet access after *unintentional*,incomplete uninstallation of Freedome

Please help.

My subscription for F-Secure Internet Security ended.. Because of my current economical situation i could not afford to renew it, so i decided to uninstall it. I had been a subscriber for couple years now, it was a sad decision but hell, what are you gonna do Smiley Sad


I selected "F-secure" on the "Uninstall or change program" list to uninstall it.


After a boot, my internet access was not working. Then i noticed my freshly purchased install of Freedome was gone too. So apparently while uninstalling Internet Security, also Freedome was uninstalled.. And for this reason now i don't have internet access.


I tried the Windows troubleshooting tool, it detects no problems.


My network connections show:

Ethernet : No internet

FreedomeVPNConnection: Network cable unplugged


Why was Freedome uninstalled in the first place? There was two enteries on the control panel list: "F-Secure" and "Freedome". I selected "F-Secure" and sure enough it messed up my Freedome installation too.




I managed to get my internet back. Lucky me i still had the F-Secure Uninstallation Tool on one of my hard drives (because it can't be downloaded from your FTP server at the moment). Running that worked. This was all because Freedome wasn't properly uninstalled, i have uninstalled it many times before the right way and nothing like this has ever happened. 


Leaving this here for anybody else who has this happen to them - Make sure you have a copy of the aforementioned tool around.


ps. My operating system is Windows 10 64-bit (OS Build 10586.318).



This discussion has been closed.
Product & Pricing Info