Ookla speedtest not recording any speed (0 upload, 0 download) on android

Hi guys,

 

Just got a subscription to Freedome and running in on my Nexus 5 (OS version 6.0.1).  When using the Ookla Speedtest app (not the mobile site) on my phone, the app records a ping but always 0 for upload and download.  I'm sure this used to work a while back during trial but maybe I'm wrong.  Is this expected?  If so, how do I test network speed with Freedome turned on?

 

Thanks

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Olivierv, 

     

    You can refer to this article for information on Ookla speedtest.

     

    Can you confirm that you get constant value of 0 even when changing virtual location?

    That might indicate some problem at your Internet connection level.

  • oliviervolivierv Posts: 3

    Hey Ben,

     

    Sorry for the delayed response.  

     

    I've tried to turn off location service, rebooted the phone, changed the virtual location (and quite a few combination of those).  I even tried on different Wifi networks, on my LTE connection.  Everything gave me contsant 0 for up/dl speed.

     

    Any other ideas?

  • JOnes1JOnes1 Posts: 4

    As a workaround,make sure you got the latest android freedome(2.1.4.3592 by now),then exclude the ookla speednet app from freedome vpn(settings),and then run the app again.Notice your are measuring your'e actual internet speed,not the fs-vpn one.

  • oliviervolivierv Posts: 3

    Thanks @JOnes1 for the way to check my connection outside of Freedome.  That's good to know. (and I'm running the latest)

     

    Obviously my goal to know my connection speed with Freedome turned on.  

     

    If any other theory/ideas from anyone emerged, feel free to chime in.

     

    Thanks

  • JOnes1JOnes1 Posts: 4
    Okey,The Ookla speednet was working with freedome on in earlier releases,something "happened" with this new one.
This discussion has been closed.