fsecure internet security does not work anymore


I've been using F-Secure for years with satisfaction and my license is still ok for at least 1 year (3 computers but only mine on windows 10).

My new Asus ROG is working on Windows 10. I installed F-Secure Internet Security on it a few weeks ago. All was fine until yesterday when at opening the computer I got the following messages:

unable to run , missing msvcr110.dll, then missing msvcp110.dll and then trigger.exe not running.

I tried to repair, not working. I tried to uninstall and re install: impossible to access due to missing trigger.exe.

I checked the Windows/syswow64 and all files are there but visibly not recognised.

I downloaded them (except Trigger.exe which i could not find) but nothing goes.

I also downloaded vcredistx86 just in case from microsoft

Please, have you got an idea for me? It looks like my antivirus is down...

Thanks for your help




  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hello Valoche,


    Can you make sure to have only the dll matching your Operating System(64 or 32 bits).


    If that doesn't help, could you open a support ticket so that we can investigate better this problem.

    Make sure to include an fsdiag to speed up the investigation.

  • valoche
    valoche Posts: 4 New Member


    Thank you for your message. After I posted yesterday, I found a tool on the fs community and could uninstall F Secure. But, I could not re- install it! It failed the 3 times I tried. Obviously, I cannot run the fsdiag anymore as you mentionned it....

    I'll try again tonight. I'll also give you my config so that you can probably help me better.


  • valoche
    valoche Posts: 4 New Member

    hello again. I tried tried again to instal F Secure today and it still fails.

    My operating system is x64 with windows 10 family.

    any idea?

  • valoche
    valoche Posts: 4 New Member
    support ticked opened...to be continued
This discussion has been closed.