Freedome blocking internet access when ON

I tried to search for an answer in the community history to my problem but it is like looking for a needle in a haystack. I have to say this community-style helpdesk is the worst invention ever...

 

But my problem is - and I hope someone can help if not F-Secure - that I turned Freedome on with UK as location and my computer would not open the webpages. As soon as I turned Freedome OFF, the website opens. But I cannot access its information because I am not located in UK. Which is the very reason I bought the Freedome licence in the first place..........

I recall sometime back reading about some trick related to a recognized network - in other words adding Freedome as a recognized network on my laptop (Windows 7). Could you advise what I should do? Until now Freedome has worked perfectly and I was a big fan. So I truly hope I can get some help this way - quick :)

Freedome is working ok on my iPad. It is only on the laptop where I have an issue.

Van1234

Best Answer

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Sinooperi,

     

    Thank you for the update. Don't hesitate to get back to us if the problem reappears.

This discussion has been closed.