iOS 9, Freedome and Airplay problems



Earlier Airplay from iPhone to car audio and Apple TV worked with Freedome enabled flawlessly. I could drive hours without having any problems or need to adjust the devices. After upgrade to iOS 9 (and maybe also upgrades to Freedome App, can't really remember) same setup and devices starting having problems.


First, Airplay devices are discovered and music is played without a problem. After few minutes (seems to vary greatly, anything from 1 to 15 or more) music suddenly stops. The device continues to stream as if there's no problem, but no music can be heard. Once Freedome is disabled/disconnected, the music continues after a few seconds. If Freedome is disabled from the beginning, there is no problems.


Question is - has Apple changed something in iOS 9 to introduce this, or has something changed in Freedome? The problem started very close to iOS 9 release and the related Freedome update.


Is there a way to fix this? It's a nuisance.



  • LakshLaksh Posts: 4,444 Community Manager

    Hi por,


    In order to understand the issue further, could you let us know if the issue occurred even with the older version of Freedome (before the update) when you had your iPhone updated to iOS9? Or it started to occur only after the update of Freedome version?


    May I know which version of Freedome is currently installed on your device?

  • porpor Posts: 16



    Unfortunately there is no clear memory footprint about the period between iOS 9 upgrade and new Freedome version and problems during. The problem might've existed, and I was hopeful about the new Freedome version fixing it, but alas, it didn't. But really, can't remember.


    Current version of Freedome is



  • Same thing here, during the last weeks Freedom seem to have had problems on my iPads, and I need to disable it in order to connect. The version number is and the iOS number is 9.2.1. Are you working on fixing this?
  • LakshLaksh Posts: 4,444 Community Manager

    Hi por,


    I did a check further with our Freedome team on this issue. This seems likely to be an iOS issue as we are using the VPN functionality built into the iOS and this blocking might happen on the OS level. In order to investigate this further, if we could get the approximate time when you started to experience this (as when the upgrade to the iOS9 happened), it might help us further.


    Also it would be interesting to know if you could turn on the Freedome Settings -> “Keep VPN on when device is idle” setting and if that helps in this case.

  • At least for me the problems started after the latest iOS update. Turning on "keep VPN on when device is idle" doesn't help. Are you working on fixing this as it is getting annoying?
  • porpor Posts: 16

    Sorry for the delay in answering. Had to try out the "Keep VPN on when device is idle" setting. No help there - similar behavior occurs even if the setting is on.


    I upgraded to iOS 9 few days after it's release, so that should've been maybe 20th of September or so. During the same time Freedome was updated as well. I noticed the problems some time after that, and I guess first Freedome update I expected to fix the problem was in early October.


    Hopefully this helps.

  • LakshLaksh Posts: 4,444 Community Manager



    As mentioned in my previous post, the issue is seen to be related on the OS level. And the issue with Airplay starting seems to have been happening with or without Freedome turned on.

  • porpor Posts: 16

    No, there's a misunderstanding. There are absolutely no problems when Freedome is off.

  • iamDavidiamDavid Posts: 4

    fyi, I  had exactly the same problem with Airplay music stopping after a few minutes when Freedome was running. For me the problem occured when i didn't touch my iPad and the device became idle, then the VPN discconnects in the background which seems to cause Airplay to stop.

    Turning on the "Keep VPN on when device is idle" setting solved the problem for me.


    What's interesting is, this means that if the iOS device (temporarily) looses the ISP internet connection (which normally does not matter if you are playing via local wifi / airplay streaming), but now the Freedome Vpn will probably disconnect, and this causes Airplay to stop (even though it's only using local Wifi and not even using the internet conncetion).


    So perhaps the problem is you are loosing internet connectivity?

  • porpor Posts: 16

    Well, could be. Especially in the car. But, setting you mention didn't help me.


    And for the record, Airplay doesn't stop - it keeps thinking it's connected and streaming as if nothing happened. Packets just don't seem to reach the Airplay enabled device. It's as if suddenly (after a reconnect of VPN or something) iPhone suddenly begins sending packets beloning to the local network via the VPN tunnel even if it should not.

This discussion has been closed.