Freedome blocks Bower traffic

Bower (http://bower.io/) is a command line tool widely used by web developers. For some reason Freedome blocks bower from downloading the dependencies while a similar tool NPM (https://www.npmjs.com/) works just fine.

 

Maybe the domain name where bower is trying to download the packages from is blacklisted by Freedome?

 

I relly like Freedome and would like to keep it activated all the time but bacause of this issue I have to turn if off several times a day. Often I forget to turn it back on too.

 

Thanks

Comments

  • LakshLaksh Posts: 4,431 Community Manager

    Hi wuher,

     

    Have you tried to turn off Tracking protection and Browsing protection (one at a time) and retry the download on the same website? Does it work?

     

    Is there any error message seen when you try to download with Freedome on?

  • wuherwuher Posts: 2

    Thanks, I tried what you suggested. It seems that bower only works if Freedome is turned off completely. It didn't help if I turned off either one option individually or both at the same time. The error message is always the same:

     

    bower ECMDERR       Failed to execute "git ls-remote --tags --heads git://github.com/ember-cli/loader.js.git", exit code of #128 fatal: unable to connect to github.com: github.com[0: 192.30.252.130]: errno=Connection refused
    
    Additional error details:
    fatal: unable to connect to github.com:
    github.com[0: 192.30.252.130]: errno=Connection refused

    I am definitely able to access github outside of bower even when freedome is on. I can also ping the above IP address without problems when freedome is on. Not sure what bower is doing differently..

  • LakshLaksh Posts: 4,431 Community Manager

    Hi wuher,

     

    If that is the case, I would recommend to open a support request or contact our chat support in order to understand the root cause of this. Please do mention about the post here so that they can have a look as well.

  • From what I understand, it's an issue with Bower. If you google Bower Ports you'll find some potentially relevant discussions where other people behind firewalls or using specific VPN connections have issues connecting using Git/Bower. I had problems earlier today while streaming YouTube - all of my SSH connections kept getting dropped, even ping failed. Meanwhile,I didn't have any problems in my browser. I highly recommend testing out this VPN service with as many specialized services as possible. There's a 30-day refund window. So far I'm not impressed, other than the browsing tracking "protection" feature. Not sure privacy-enhancing features are worth the tradeoff in stability and speed I'm currently experiencing. 

This discussion has been closed.