problems after bios upgrade

Hello,f secure community..i have a 3month trial of f secure safe from your official site,after i used your free online asked,if i'd like to use your 3month trial and i accepted.your app,run smoothly,alongside:microsoft emet,malwarebytes antiexploit,malwarebytes(free),superantispyware(free),toolwiz timefreeze.i didnt have any cracked or pirated software,in my system.i updated windows to the latest and i set my router's firewall to the most secure settings.i cleared all my browsers,everyday.i run scans,almost everyday..i had no problems..i used adwcleaner and ccleaner,for better cleaning.i have a lenovo g50-45,windows 8.1 with bing.i wanted to install virtualbox and in order to do that,i had to upgrade my bios.i downloaded the bios exe,from lenovos official site and the installation,went problemfree..after that,for about 2 hrs,everything was ok..the day after,f secure didnt load(the icon) and in the taskmanager were running some tasks of your app,but not the .exe.i didnt find a way to run,your app..after i reboot,your app,was ok.but then,most of the times,same .exe,after boot or reboot.also there was a slowdown,in my system and i observed that antiexploit,had the same problem.i forgot to mention that your desktops shortcut i moved it in a file,to open it,from there.i thought that timefreeze,made the problems and i uninstalled it,but no luck again..i run a scan(when i had the chance)with your app and no virus,was found.i boot to safe mode and run a scan with adwcleaner,malwarebytes and superantispyware and nothing was found..i uninstall your app and reinstalled it,but no luck again.i disabled amd svm(which i enabled for virtualbox)cause i thought that was the problem,but,i believe that bios upgrade is the problem,but im not sure..what do u believe?unfortunately,i installed my windows iso(the original factory settings)and i havent installed your app yet,cause i need your has a trial of mcaffee,which until now,didnt have any problem.i hope,i sent to the right email address,my issue with f secure..if u need any more information,about,i'd be happy to tell you..thanx,in advance..if i sent it,to a wrong address,please send me an email only with the email address,where i should send..pc info:lenovo g50-45,windows 8.1 with bing,notebook,dual core 1.33,4gb ram,fully updated,amd catalyst(radeon r2).also,secureboot,is enabled in bios.(i believe that maybe the problem occurs,with the startup apps.anti-exploit and f secure boot at startup.bios upgrade issue???).

I hope i am quite informative and descriptive..
Keep up the good work..
Untill this issue(which i dont say,that u r responsible,i just hope u can find a sollution)i was completely satisfied..


  • Simon
    Simon Posts: 2,667 Superuser

    I don't think I can help with your specific issue, because it's a bit too technical for me, but I do know that you can only install the trial version of F-Secure once, so that may be one of your problems.


    McAfee would certainly be another problem, so if you intend to use F-Secure, you need to ensure that McAfee is completely removed.  Here is a list of Uninstallation Tools, but I'm not sure how current they are, so you may want to do another search for that.


    Further, if you choose to continue to use F-Secure, as you have already tried to install it unsuccessfully, I would recommend that you run the F-Secure Uninstallation Tool to remove all possible debris from a previous attempt, and start again.

This discussion has been closed.
Pricing & Product Info