Freedome VPN is very slow on some connections and not other

eric1 Posts: 6 New Member



I use Freedome in  travel, over a wifi hotspot. Without Freedome enabled, the wifi connection is respectable. With Freemdome enabled though, the connection is unpracticable (very very slow, some http resources like images or css not downloaded, etc.).


At the exact same place, I tried freedome (same VPN location) with a 4G connection shared in wifi on my iphone. The connexion is normal (not slow).


What can explain that difference and above all what can I do to use Freedome on the wifi hotspot ?


I suspect a bad behavior / parameter from freedome because the wifi connection alone seems to be pretty good.


UPDATE: after a connection speed test, it seems the wifi connection is acceptable for downloads but very slow for uploads. I suppose freedome need a good upload speed for use...




  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello Eric1,


    We do not limit download or upload on our virtual locations. Could you tell us if you get slow upload speed on all virtual locations or only on one particular location?


    Note that any VPN will slow the connection to a certain extend. See this article fro more information on that.


    Also note that tethering is not officially supported and that could explain the poor results you had for these tests.




  • eric1
    eric1 Posts: 6 New Member

    I think there is something on the wifi hotspot which blocks vpn usage.


    I tried two different locations (Paris and Milan) and it is the same problem. When Freedome is enabled, I see nearly no traffic on network activity monitor: always less than 10 packets/sec, and most of the time 0, while I try to browse internet. When Freedome is disabled, I see way lot more activity (tens or hundreds packets/s).


    The problem is not teethering which works well, with ou without Freedome. The problem affects only the wifi hotspot I can access in my current location.


    Thanks anyway for your response.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi eric1,


    Hope this article might provide some insights on this issue. It might be that VPN protocol is not allowed on that Wi-Fi network.

  • eric1
    eric1 Posts: 6 New Member

    Thanks Laksh.


    FYI there was effectively a login required on the wifi. As suggested in the article, I first login on insecured connection and then I enabled Freedome. The establishment of VPN connection was very slow but succeed (freedome enabled), but after that, the wifi connection wasn't usable until I disable freedome.


    Perhaps VPN was not allowed on the wifi hotspot. But in that case, I expect Freedome to tell me that the connection is not working. If the graphical interface of Freedome displays "Protection ON", I expect the connection is working. That was not the case.


This discussion has been closed.
Product & Pricing Info