Why won't Frontier Secure accept my input?


I have been trying for over an hour now to run a prototype for a game that a friend is developing.  At first I seemed to have trouble even downloading the file, but I told F-Secure to admit it as an exception.  It seemed to be responding to/trying to remove the setup.exe.


Once I downloaded it all fine, trying to actually RUN setup.exe just produces a little pop-up window down in the corner of my screen telling me a Trojan was discovered, but don't worry, we blocked it!  As it is, I find it to be a design flaw that I'm presented with the options, either "[ ] Handle Automatically (Recommended)" or else, "Clean the file, Quarantine the file, Delete the file, Only block the file..."  shouldn't there also be an option for, "I know what I'm doing, actually, so please, ALLOW the file..?"


At this point, I've weeded out residual Norton360 files from something either my mother or sister (previous owners of this computer) may have put on, or which may have been added with the startup package.  In any case, it wasn't working, it wouldn't open and told me to contact support about that, but it seemed to be trying to be active anyway, showing me where it was blocking apps.  I thought for sure that was the problem.


I got rid of every trace of Norton360, but the error affecting setup.exe has not changed, which, by process of elimination, says it has to be the only other security program I have, Frontier.


Now, when I try to run setup.exe, it simply doesn't run, and then I learn it's been helpfully intercepted for me by Frontier.  I've long since made the whole folder an exception to Frontier scans, I've made sure it's not Read Only, I've hunted through Quarantine and Removal History lists and tried to exempt it or restore it from anywhere it might be tagged - everywhere I can see, within my settings, it seems like it should be allowing what I want to do.  I even pre-made the installation directory the setup.exe is GOING to try and use and exempted THAT from Frontier!


Obviously, none of that did anything.  I hate to do this, for any reason, much less one which involves me being connected to the internet, but I was forced to turn off Frontier altogether, for lack of any other options.


Every time the file is blocked it remains in a corrupted state (setup.0xe) and won't allow me to delete it, rename it, move it, anything.  It tells me MYCOMPUTERNAME needs permission or won't supply permission or something.  If I open F-Secure the ugly artefact file goes away.  If I close F-Secure, it always makes sure to detect that setup.exe and corrupt it for me before it closes out.  So I try leaving it off completely, re-downloading the file, and trying to run the setup.exe.


NOW I am just getting F-Secure content in pop-up messages, except they aren't even F-Secure pop-up windows, they're ordinary Red-Circle-White-X Windows Error pop-ups, and they appear incessantly (close one, another appears, close one, another appears, etc) until I turn off F-Secure Host App in Task Manager Processes... which I thought I disabled from auto-opening on startup...?


What I can tell for sure is that the security program has a problem with this home-baked executable file. It wants to tell me it either contains a Trojan or is one.  As I've said, I happen to know it's not.  This homemade game idea would be an awesome project to get in on, and I'll absolutely be invited to do texture art and 3D modeling for it - provided I can just open the **bleep** thing and look at it on my machine... but if I can't even get past the setup.exe on my own, chances are I won't be seen as someone who won't slow down the team...


...Not that any of this is relevant to F-Secure, or that it would be F-Secure's fault if I missed the opportunity (because of this persistent error) - but this is all just to ask, really:


Why don't I have permission to run a file which I know, I trust, and I chose, on my own machine???


Why, even after hitting "Turn off all security features," is some part of Frontier still active???


Why isn't it enough to just except it from the scan?  And to exclude from the scan anything which seems to be even touching it by one degree of /directories?   What else am I not doing?


The only thing I can think to do at this point is to flat out uninstall what is now my only security application, which is why I've come here first, to ask advice and see what it is that I'm missing.  I've been telling myself that surely there's some little toggle or setting I've missed, but really though, when you can purport to turn the whole application off, and find it still not only running in your Processes, but even *still* attempting to block files from action in a sort of half-functional, zombified state, presenting as some sort of system error but crudely succeeding at blocking the .exe...?   That starts to seem more like a problem, and less like some setting I've missed.


So at this point I don't know what to do.  My issue is simple, really - I have a homemade executable file.  Frontier can tell it wasn't made by Microsoft or something so it thinks it's a Trojan.  My every attempt to allow the file, Frontier counters, perhaps thinking I must not know what i'm doing, or that it must be the Trojan trying to do that... in any case, it fights my ability to open this file right down to its dying breath, as a turned-off ghost in my Processes, manifesting not in its own form but as a red-circle-white-x Windows error message.  Something tells me even if I did uninstall Frontier it would find a way to combat this file from beyond the grave.


I'm babbling.  But my point remains - I am out of ideas for how to simply allow this file.  Someone please, read through what I've tried already, and what's happened as a result, and tell me what might have gone wrong, and how I can fix it.  For the record, I would just reinstall Frontier if I knew how it got on there - like I say, previous owners, who don't know/remember themselves - maybe a startup pack?  In the morning I'll be calling some kind of 800 number for Frontier and I'm sure they can help figure it out, but it seems worth asking here, too.  Seems possible someone else might have had this problem before.


LONG STORY SHORT: Frontier not only blocks a homemade setup.exe, but blocks my every attempt to allow it.  Even after I turn Frontier off.  I am confident by the content of the Windows Error message that presents instead that the problem is with Frontier - it's the same text from a Frontier "___ware detected" error.  How do I allow this setup.exe??


If anyone slogs through this whole post, never mind actually being able to offer up a solution, I'll be extremely grateful.  This isn't the first error of this kind I've had with antivirus/security applications, but it's the first one I can't seem to resolve on my own, using the ordinary in-program settings...  Hopefully I've provided enough info about what happens to be useful.  Ask me whatever else, please.


The pink-on-black slogan on the banner just below where I'm typing now says "F-Secure - Switch On Freedom."  That is quite literally *exacty* what I am trying to do right now.  Haha.


Thanks so much to anyone who's taken the time to read this.  Here's hoping you've got an answer for me...!  Any advice whatsoever is much appreciated here.


  • Simon
    Simon Posts: 2,667 Superuser

    I think I got the basic gist of all that.  So, essentially, you want to stop F-Secure responding to this file as a Trojan, when it isn't?  What I would suggest is that you submit the file for analysis at the labs, then they can whitelist it for you if it is deemed safe to do so.  This is usually a fairly quick process and you can do this by clicking here:


    Submit Sample

  • Ukko
    Ukko Posts: 3,640 Superuser



    Sorry for my reply.

    As additional for previous suggestion about "transferring sample to F-Secure SAS" and... as result... receive "drop-status for detection" or.... detection was with reasons.


    Anyway... about your three questions. I can to think about next things around:


    -->  Potentially you should have permission to run file, which known for you as trusted, clean/safe on your machine.

    But from first.... I'm not sure about points... what if your version like (Frontier-based) have some of mistakes (such as.. most likely Frontier-solution based on a little be outdated version of F-Secure solutions; Such as maybe there was some of related mistake and it's already fixed with F-Secure solutions... but Frontier does not have updates yet).


    Also it's based on detection type and how it's happened.

    With potentially unwanted software or adware... most likely will be pop-up about "available option" to exclude this file (if it's known as safe for you).

    With malicious files... by default... it's tried to be removed/cleaned. For this kind..... required exception list, of course. But it's should not work.... when you launch direct scan for "file". With this step.. detection should be (does not matter if file is excluded from scanning). But just... "direct scan" for "certain file".

    Or other situations (can be some of troubles with "hosts"-file) or detections by DeepGuard. Most likely there should be steps for get normal work.


    --> "Turn Off all security features" goes be work for one module (and not for full solution of F-Secure).

    So.. most likely some part of Frontier with active-status was based on main hoster-processes, another module (Online Safety / Browsing Protection?! such as web-protection, ratings and other). And related things.

    For example.... it's required for normally "turn on all security features" back. Most likely you able to do this.. just by choosing tray-picture or logo-desktop. And does not launch it again.. by some of hard steps.


    There have steps to full disable F-Secure solutions (but I'm not sure.. that it's can be work for Frontier). It's not common steps... and probably it's should be not helpful for your situation.

    Such as... security features with your experience most likely was disabled.

    Another part of Frontier based on common and web-protection modules. For retrieve security features by one-step and for web-protection.. when "Computer Security/AV"-part is disabled.


    --> Potentially should be enough exception-step. 

    Maybe your file have some of another background.

    My potential steps about same situation can be like that (for example):

     -  "Turn off all security features".

     -  Download the file.

     - Place it to (for example): H:\Files\Downloaded\Game   ; and file will be as "H:\Files\Downloaded\Game\setup.exe"

     - Goes away from folder.

     - "Turn on all security features".

     - Goes to Settings about real-time scanning (where we can to see options for "Auto-handle and mail-attachments" - choose "Exclude/Exception" list. And add for "second tab" destination  H:\Files\Downloaded\Game   

    Check this and save it.

     - Goes to Manual scan settings (it's another one exception list; work just for manual scan). And to do same steps as before.


     - Goes to folder and will try launch setup.exe

    Potentially it's should be work. If not.... we can to think more.


    With your description was same words... but it was after a lot of tries. So.. maybe it was already not so "fresh". And you can try to do this again.... or will say... if my example-steps was same with your try.


    For example.. it was work with my try... but I check it with "safe-sample"... and not sure... that it's certainly should to work with your file.... or if Frontier-version should to work with my version of F-Secure.


    But anyway.. what if my words can be partly helpful (as additional... for time... when F-Secure SAS can to check your file - if you decided to use it).

This discussion has been closed.
Pricing & Product Info