Connecting...

Freedome says "connecting" and nothing more. It doesn't matter which location is set. I'm using WIN 10 X64 and Freedome 1.00.2246.0. Ip address is not hidden. Tried to update but that didn't help.

Best Answer

Comments

  • LakshLaksh Posts: 4,439 Community Manager

    Hi Dzeko22,

     

    Is there any other error message seen when it tries to connect to the locations?

     

    As reported before in this thread with the similar issue, we have received reports about this issue and our RND team is investigating further. However, I would recommend to open a support ticket from here and provide all the details of the issue so that our support team can communicate further.

  • LakshLaksh Posts: 4,439 Community Manager

    Hi Dzeko22,

     

    Thanks for your update on the issue and glad to know it is resolved now.

  • I have the same problem, and contacted the support. No response yet, though it's been 10 days. But long waits seem to be the norm here, too. While I have been waiting for an answer, the 30 day money back period has expired.

     

    Freedome can't connect to any server, thus I can't get to internet - unless I disable the protection. I tried re-installing, it helped for that session only, after reboot, it's the same problem again.

    Windows 10 and Freedome are both uptodate.

  • WexuWexu Posts: 1

    Yes, me too having this same problem. Re-install made it work this time but haven't yet tried re-booting after this latest installation. This is now the 2nd time this problem occured on my PC. This PC has Win8.1 and 1.2.2729.0 version of the Freedome. I have another PC that still has Win7 and that one has worked like a charm all the time since starting to use this Freedome about a month ago.

This discussion has been closed.