Freedome Won't Start Since Updating to Win 10 Nov Release

I updated to the Nov release of Win 10 on my tablet and now Freedome won't connect. I uninstalled and then reinstalled it twice but it still won't connect. There is no warning message just "Protection OFF" all the time. I've set Freedome to start with win 10 but no luck. I also tried pressing and clicking the protection button but nothing happens. Dead as a dodo. After a very long while of nothing happening a message asking me to save an error report pops up. How do I send you this report? When I reinstalled Freedome it took longer to install than usual in case that's relevent. Using version 1.0.2246.0

Comments

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Spectralis,

     

    I would recommend you to open a support ticket in order to check on your crash logs or for futher troubleshooting. Kindly open your ticket here.

     

    Do you see any error message when you try to turn on your Freedome? If yes, do post your error message along with the ticket.

  • I tried reinstalling Freedome again but when I tried to enter my reg code I received a message saying my 3 device subscription was used up. This is impossible because I have only just managed to reinstall it on a single device (my laptop) as I've uninstalled it from my other device (a tablet.) My third device will be my windows phone when Microsoft release the Win 10 phone upgrade.  Judging by the large number of threads about Windows 10 problems I would have though F-Secure could have prepared for Win 10 a lot better than it has. I've sent a support ticket. 

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Spectralis,

     

    Thanks for your feedback on the issue. However, I did notice your have opened a support ticket for this issue. Your issue will be handled through the ticket so that it is easy for further communication.

This discussion has been closed.