Visual Studio Android emulator causes disconnect

Hi, I'm running Freedome on Win 8.1 64 bit and Win10 64 bit systems. Running fine until I installed the Android development system under Visual Studio 2015.

 

When the Emulator starts from Visual Studio - you are asked:

"Do you want to configure the emulator to connect to the internet?

Your computer may lose network connectivity while these changes are applied. This might affect existing network operations.

Yes   No"

 

Answering Yes does what it says and destroys the Freedome VPN connection. In my case it switched off all the Network protocols under the Freedome TAP driver apart from one. Both IPv4 and IPv6 were switched off.

 

When trying to connect you get the usual:

"Freedome

VPN initialisation error

Your encrypted VPN connection cannot be created because of issues with network configuration (netsh.exe fails). Please check that you have IPv6 traffic enabled."

 

I have tried the connection renaming "fix" described elsewhere - this worked on one Windows 10 system but becomes very tedious when you have to do it everytime the Android Emulator is started up. It does not work on the Win 8.1 computer.

So far the only quick solution has been to uninstall and reinstall Freedome. This is also incredibly tedious.

I would hope that Freedome was much more resilient than this - effcetively an "attack" on the network connections by the Visual Studio Android emulator and Freedome throws up it's hands and surrenders. Come on F-Secure, I'm sure you can do better than that Smiley Wink

 

 

 

This discussion has been closed.