Freedome won't open after update

Bought SAFE (1 year for 5 devices) months ago, received an email about a voucher for 1 year use of Freedome (in august to be used before 30.9.2015). Have SAFE installed on 3 devices.

 

Took that offer and installed Freedome onto two computers. One computer (win 7) has not had Freedone used or updated since installation and is version 1.0.1958.0  it also says that the subscription is active and has 351 days left.

 

Second computer (win 8) received a notification on 13.11.2015 about an update, similar to notifications that I had installed before. This time it started and almost finished the download (is it a bar that fills up, can't remember) but before finishing a small window appeared and it read "Something went wrong" and closed the update. I then tried to open Freedome and a couple times it did open only to have the same message "Something went wrong" to appear, tried again same message and then it no longer opened the Freedome program, even now I just try clicking at the icon and nothing happens.

 

I've seen some similar messages on the boards and the mods asking for version numbers, in the case of this problematic Freedome program I can't open it to view the version.

EDIT:  1.0.2085.0

ALSO- Freedome is active and on (according to processes) but cannot open the program.

Comments

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Tmcs,

     

    May I know if the recent version of Freedome installed on your computer is 1.0.2085.0 or it the version before the upgrade?

     

    We do have a few reports of Freedome upgrade issue and Windows 10 with the same error message. However, we would like to know if there was any Windows Updates installed before or after the Freedome upgrade was installed?

     

    Since you mentioned it seems to be active and turned on, have you tried to restart your computer and check if Freedome can be opened?

  • TmcsTmcs Posts: 2
    It is version 1.0.2085.0 I don't know if that is the updated version, I thought the update didn't go through because of the error message.

    I have windows 8

    There were windows updates the day before (12th), Freedome update (13th). I also tried a system restore on the 13th to a few days earlier, Freedome did not open,re-updated windows, but Freedome remained un-openable.

    Have restarted, but Freedome won't open.
  • LakshLaksh Posts: 4,440 Community Manager

    Hi Tmcs,

     

    The version which will show after the upgrade should be 1.0.2246. So, the version you are currently showing is the old version which might have been due to the system restore to an earlier date.

     

    In this case, it is best to open a support request as per the link below with the details of your upgrade, screenshot of any error seen and other details about your device. They will look at the logs for further troubleshooting. Open the support request here:

    https://www.f-secure.com/en/web/home_global/support/support-request

This discussion has been closed.