Freedome will not work!

G'day,

 

Just bought a sub to Freedome because I'm travelling in China and want access to FB/Youtube etc.

 

However, after installing, I click connect [to the Australia server], it says it connects... But then I go to my browser etc and it claims I have no connection to the internet.

 

Can someone please assist me?

 

Thank you

Comments

  • ViiviViivi Posts: 1

    I have same issue. It worked fine couple weeks and then nothing. For me it says that it doesn't get contact to net but since rest of the programs gets the contact fine the issue is with freedome. I have now spent almost 60 days from my subscription and the freedome worked maybe couple weeks from those.

     

     

    Have tried to find reason for the issue couple weeks now, and I have to say that it is bit annoying too that you can't contact anywhere straight, but you have to go to public forum with these problems.

  • LakshLaksh Posts: 4,440 Community Manager

    Hi Masoneilan,

     

    Have you tried to connect to other locations apart from the Australian server and see if the connection happens successfully?

This discussion has been closed.