Tunnelblick for earlier versions of Mac OS X

Is it possible to use Tunnelblick to access a Freedome server? I have OS X version 10.7 which is not compatible with the Freedome software.

Best Answer

This discussion has been closed.