App won't let me use my existing subscription on my iPhone

AwesomeNick566 Posts: 1 New Member
Hello, while on my iPad, I purchased a subscription for Freedome.
I am trying to get this on my iPhone (both devices have same Apple ID) by pressing "restore purchases" but it just says "Restoring purchases" for a long time. It also says something about not being able to accept payment at this time. It might be worth including that my iPhone subscription status was "EXPIRED" when I tried to restore purchases.

Freedome Version
iPhone7,2 iOS 9.0.2

Sent from my iPhone


  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi AwesomeNick566,


    Are you trying to restore your purchase on your iPhone via the app store purchase? If yes, as mentioned in the article here, you should be able to use your app store subscription on your iPhone as well. have you tried to uninstall and reinstall the application on your iPhone and use the same app store subscription for validation? You can download the Freedome application from the Apple app store.




This discussion has been closed.
Product & Pricing Info