F-Secure Freedome unable to start protection


I have posted this message two weeks ago but didn't get any answer.

I have been using Freedome on my surface pro 3 running on windows 10 without any problem. Then F-secure released a new update which I installed. Since then Freedome stopped working . The protection remains OFF and there is nothing I can do to change that. I uninstalled the software using the uninstall tool then I tried to reinstall without success. I have exactly the same results. After a while I have a message saying there is a problem and a diagnose option which just creates the fsdiag.7z file. It is a bit frustrating for a tool that I paid for and which used to work fine before.

More over I paid for 3 instalations and when I reinstalled it deducted one activation so when I tried to activate it on my iphone today (I already have it on an ipad) it didn't accept it. So I would like to have an other activation key please

I hope you can find a solution quickly.

Thank you



  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Gau,


    Sorry to hear about the inconvenience with the Freedome installation!


    Is there any error message in particular you see when you try to turn on your Freedome product? Please post a screenshot if there is any error. What is the current version of your Freedome product on your Windows 10?


    About the licensing issue, could you please send me a private message of your Freedome code and the screenshot of the error message seen during the validation in your iPhone so that I can check further on this? How many devices are currently using the Freedome code?

  • Gau
    Gau Posts: 3

    I was using version 1.0.1958.0 and I just updated to version 1.0.2085.0 with the same result:FSECURE ERROR.PNG

    The error message is in French as well as my system. It just says "Error, Sorry a problem occured" which doesn't help me much. I created the fsdiag.7zip file but it is of no use to me.


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Gau,


    I have sent you a private message in order to discuss further on this issue.

  • ptrck
    ptrck Posts: 2

    I have exactly the same problem. Loaded Freedome but unable to activate it. Same error message. 

    I'm using Windows 10

  • Are you by any chance running Kaspersky AV?


    If so, I had the same issue and it was only fixed by removing it...

  • ptrck
    ptrck Posts: 2

    Thanks trying to help me

    I'm not running Kaspersky, I'm running Avast and already tried to desactivate it in the way to get Freedome. But it fails

  • Disabling your AV may not be sufficient, I had to uninstall KAV for Freeddome to work properly on Windows 10.


This discussion has been closed.
Product & Pricing Info