Freedom Voucher

Hello, recently I was lucky enough to receive a voucher to evaluate your excellent multi-device Freedom VPN product for a year. Recently I had cause to reimage my devices (I am a security guy and often comes with the territory). Since I reimaged, the voucher that you were kind enough to provide me with is no longer accepted. I have read elsewhere that this voucher is for a one-time only install. It would be excellent to continue my evaluation of the freedom product, if possible, as I have a some clients who are looking for a commercial VPN solution. I also be interested to evaluate some of your other privacy enhacing products and suitability for commercial environments. The voucher I was provided with is xxxx-xxxx-xxxx. The accompanying message read: Diese Nachricht enthält die Information, wie Sie F-Secure Freedome als Teil von F-Secure SAFE aktivierien können. Hier ist, was sie tun müssen, um den Service zu aktivieren.

 

EDIT: Removed license information

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi AJB,

     

    May I know if you received your Freedome code from the SAFE account you registered for? Did you purchase the SAFE licenses for your SAFE account or is it a trial account?

     

  • Have the same problem. Got vouchers on 24/09 which work perfectly fine. Using one for my computer, one for my phone and wanted to activate one for my tablet. But every time I try to activate my code it says "Error. Code was not correct". Is there a way to use one code for both mobile devices (phone and tablet) by restoring (which is not working because i did not buy my subscription) within the App Store? Both devices are iOS. Logged into my SAFE Account and it expired on 24/10 because it was a trial
  • LakshLaksh Posts: 4,444 Community Manager

    Hi PC-Principle,

     

    If you are trying to get/use the Freedome code via a trial SAFE account, please be informed that our limited offer (ended on 30th of September) was a “Buy SAFE, Get 1year of Freedome for free” offer. Consumers who do not pay for SAFE after the trial period, will be prompted to pay to continue using Freedome for free.

    Even if some may have abused our offer, Free Freedome Premium with SAFE trial was not offered by us, and it won’t be supported by F-Secure.

  • I purchased a 2 year subscription to SAFE in August 2015 which came with the free 1 year trial of Freedome. After a recent update, Freedome failed and I have been unable to re-activate it. I tried removing Freedome and re-installing it but the original voucher expired on September 30 of course.

    Given that I have paid for my SAFE software and that the Freedome 1 year free trial was offered as part of this, is F-Secure able to send me a new code? Remember that it was the update that caused it to fail.

  • LakshLaksh Posts: 4,444 Community Manager

    Hello CryptIdiot,

     

    The code for the Freedome campaign cannot be re-used anymore as the campaign has ended. The Freedome campaign (via Safe) was a limited offer which ended by September 30th, 2015. The codes will continue to be valid (if you have purchased SAFE) for a year on the already installed device with Freedome.


  • Laksh wrote:   (snip) The codes will continue to be valid (if you have purchased SAFE) for a year on the already installed device with Freedome.

    But I have purchased SAFE. I have a 2 year subscription for 3 devices with about 21 months left to run. This purchase was made in August and Freedome was installed and activated/registered in August - well before the September 30 deadline. However, it recently crashed. I tried re-installing Freedome but the installation codes for Freedome keep saying "Subscription Expired".

     

    The 12 month Freedome subscription was offered as part of the SAFE offer. It was the latest update that caused it to crash and become un-usuable. You seem to be agreeing that someone who has purchased a SAFE subscription is entitled to the 12 month Freedome offer but this isn't what I'm getting. I hope you can fix this problem somehow.

     

    Thanks.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi CryptIdiot,

     

    If the upgrade caused the Freedome product to fail or if it did not turn on, kindly post about the upgrade failure in the Community so that we can investigate about it further before you proceed to uninstall/reinstall. The Freedome code is valid per installation, so when you reinstall it, the code has already been used. Our RND team is working on fixing this issue.

     

    However, for this issue, I will send you a private message to discuss further.

    CryptIdiot
  • As it happened several weeks ago I only remember after accepting the automatic upgrade, a message popped up to say "Something has gone wrong. Freedome unable to load"...or something like that. At first I hoped that simply restarting the machine would set Freedome back to its former state and at least I could use that but the damage seemed permanent.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi CryptIdiot,

     

    What is the version of Freedome installed currently on your machine? What is the OS of your machine?

     

    Do you have a screenshot of the error message as well?

  • Sorry I didn't think to get a screenshot at the time. It was being used on Windows 10, Home Edition, 64 bit. I finished up removing Freedome from that computer while it wasn't validating (rather than leave it in an uncertain state) so I don't know the exact version, but it would have been the version prior to the update rolled out about 4 weeks ago.

     

    I think it had also been updated about a month before that as well - and that update worked fine.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi CryptIdiot,

     

    Regarding your issue, I would recommend to install Freedome again with the current code. If there is any issue with the Freedome, please report back so that it can be checked further.

    CryptIdiot
  • Excellent - thanks for your help with this. My internet service had been dead for a week (on the computer where this Freedome problem occurred) so I've only just been able to try out your new code on a re-installation. It's works fine again.

This discussion has been closed.