Can't access iOS and osx app store if Freedome is on and WiFi keeps disconnecting

mrright77 Posts: 2 New Member

Hi, I'm really having a bad time with Freedome.

I got used to the slow speed (very slow) but what I experienced last week is just crazy.

I tried to update some apps on app store and every time I failed both on Ios and Osx El Capitan, most of the time I couldn0t even connect to the stores.

I thought it was my fault so I erased my Ipad, my macbook, clean installed everything os and reset my router.

Nothing changed, I wasn't able to update anything and when I tried to download something using Safari the wifi kept disconnecting. 

Suddenly I realized that disabling Freedome everything works like a charm. No wifi disconnection. Apps update worked, everything works like it's supposed to. I can't really think this app is so bad, so please give me an advice to work this out.


  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi mrright77,


    Sorry to hear about the bad experience! However, did the issue with the connection happen on only a particular location/server or did it happened with all the servers?


    Did the connection issue happen only with the App stores or for opening other webpages/accessing other applications as well?


    May i know what is the OS of your Macbook and your iPad?

  • mrright77
    mrright77 Posts: 2 New Member

    OSX 10.11.1, IOS 9.1


    I mostly use the German server since the one I'd like to use (the Italian) is very slow (I mean it cuts the speed in half).


    Today I have no problem with the stores but yesterday I had to stop the VPN since I was trying to download a 14 MB file at 2kb/s with freedome on...

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi mrright77,


    Thank you for your update on the post! So, the issue was happening on a particular location Germany when you were trying to download the files from the app store.


    I will update the Freedome team about the bandwidth issue on the respective location. Please do update us if the issue happens again.

This discussion has been closed.
Product & Pricing Info