Freedome trying to connect for hourse, not working.

Hi everyone,

 

I've bought a one year subscription last saturday. I've entered my code, perfect, i can see 365 days left on the software. Since Sunday when I'm trying to connect, it's trying to connect, to log in , but nothing happens, no problem error...

 

How is that possible ?

Thanks for your help

 

Here is a screenshot

 

Freedome Screenshot.png

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello egaurand,

     

    Did you already tried to connect to another location? 

    What kind of network are you on(3G, 4G, WIFI)? Can you try an alternative one?

  • Yes I'm trying every location ,nothing works..

    I'm using Wifi, I tried with the 3g of my Iphone, doesn't work neither

  • same here today android & windows 7 not working but iphone six no problem
  • KaraokeKaraoke Posts: 11

    Same here! All the 23 locations/servers are down.

    Freedome is a crap. I have paid for a one-year subscription and now I am starting to feel regretful. Waste of money!

  • problem solved .
    thanx
This discussion has been closed.