F-Secure Freedome installation failed

Yesterday I paid online for the F-secure Freedome and got a confirmation email. I have a Macbook Air and so I downloaded the file Freedome.dmg. Then I moved the download into the Applications folder and tried to open it, but nothing happens. It doesn´t let me type in the code and no new window opens. I have tried to uninstall the file and install it again several times, but I do not manage to install it.

 

Any suggestions how to proceed?

 

 

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello norpaaa,

     

    In order to make sure all traces of the broken installation are removed, please proceed to uninstall as follows if any is still present:

    -Remove Freedome from /Applications. 

    - Delete the folders "/Library/Application Support/F-Secure/FSFreedome" and "~/Library/Application Support/F-Secure/FSFreedome" 

    -Remove "Your F-Secure Freedome Key" from your login keychain (it's in Passwords category).

    -Reinstall the latest version available here.

     

    Could you tell us the version of the OSX install on you Macbook?

  • Hi Ben,

     

    thank you for your reply.

     

    I removed Freedome from the /Apllications, but I can´t find Freedome in my Library. After Library I chose the Application Support, but there is no such file as F-Secure.

     

     

    I tried to install Freedome once more and always the same thing happens. After dowloading I move it to the Applications folder and try to open Freedome. At this point I always get a warning, asking me if I want to open this application because it is downloaded from the Internet. I click open and after that nothing happens.

     

    The version of OSX installed on my Macbook is Mac OS X Lion 10.7.5 (11G63).

  • Same issue here - it crashes as soon as it is run on osx lion (10.7.5).

     

    Here's the error from console:

    Process:         launchd [541]
    Path:            /Applications/Freedome.app/Contents/MacOS/Freedome
    Identifier:      com.fsecure.freedome.osx
    Version:         ??? (???)
    Code Type:       X86-64 (Native)
    Parent Process:  launchd [118]

    Date/Time:       2015-10-18 17:54:22.200 +1100
    OS Version:      Mac OS X 10.7.5 (11G63)
    Report Version:  9

    Crashed Thread:  Unknown

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

     

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi guys,

     

    Unfortunately Freedome requires OSX 10.9 or more recent.

     

    See the product page for the Supported platforms:

    Windows 7 or later
    OS X 10.9 or later
    Android 4.0.3 or later
    iOS 7 or later
    Kindle Fire OS

  • GauGau Posts: 3

    Hello,

    I have kind of the same problem. I have been using Freedome on my surface pro 3 running on windows 10 without any problem. Then F-secure released a new update which I installed. Since then Freedome stopped working . The protection remains OFF and there is nothing I can do to change that. I uninstalled the software using the uninstall tool then I tried to reinstall without success. I have exactly the same results. After a while I have a message saying there is a problem and a diagnose option which just creates the fsdiag.7z file. It is a bit frustrating for a tool that I paid for and which used to work fine before. I hope you can find a solution quickly.

    Thank you

This discussion has been closed.