Question about "Application blocked" popup window

Hey

 

I have a question; is there something supposed to happen when i click "Show more"? Is it supposed to expand and show some information, like maybe the address / protocol / port where the application is trying to connect? Because i think i have seen something like that previously happen, i'm not sure though. But at least lately everytime i get one of these, i try to click "Show more" to get some more informartion about the request but nothing is available?

 

Using the latest F-Secure Internet Security 16.0.

 

Capture.PNG

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi GaryB00zey,

     

    Usually when you click on Details/Show more, the details section will show you the location of the application, the reputation of the application in the Security cloud, how common the application is and what/where it tried to connect.

     

    If you suspect the application, then I would recommend to submit a sample of the application to our labs for analysis.

  • No, i don't suspect any of the apps. The digital signatures are ok, etc.

    Has nothing to do with the legitimacy of the applications i run.

     

    Leaktest from GRC, for example.. i get the popup window and yet again "Show more" gives me no details - Is this how it's desgined ot be? Why even have the "Show more" in the window if it never gives you any more information?

     

    https://www.grc.com/lt/leaktest.htm

     

  • UkkoUkko Posts: 3,213 Superuser

    Hello,

     

    Sorry for my reply.

    It's should be "expand"-action, when you choose "Show more"-button.

     

    If there "nothing happened"... probably something goes wrong. I'm not sure about version of your installation (such as.. can not to check it right now), but probably if it's something "not just a local situation" - it's should be known situation (and should be description for current trouble under community as example). Maybe there was something about DeepGuard UI changes as fix for something (not sure now). Or maybe there just goes to be broken part of installation (and not just DeepGuard prompts). Or maybe there something else (?!) - but it's can be anything maybe.

    I goes to re-check it with latest TP-version of F-Secure IS (Fs protection) and DeepGuard prompt about Leaktest will be with normal "Show more"-button under my device.

     

    Show more with current sample will be about "riskware" (probably). And "more information" will be just about destination, reputation under Security cloud and how common application under other users.

    Such as: folder (where launch happened), malicious application (riskware?!), normal (so so).

     

    With other types of block-prompts (unknown application trying to do network connection) will be also "IP/port" information (for example) or other related information (exploit-block-action).

  • Yeah, well, like i said i don't get details. Like just now i once again tried the LeakTest, launching it - i get the "Application blocked" popup window but nothing happens when clicking the "Show more".

     

    It's a sad situation.

  • UkkoUkko Posts: 3,213 Superuser

    Hello,

     

    So... maybe you have to create a support ticket with fsdiag.7z (by F-Secure Support tool);

    With description about trouble-situation (and after reproduce it).

    https://www.f-secure.com/en/web/home_global/support/support-request

     

     

    I goes to re-check release-notes about my "dreams" around something was related maybe.

    And it was under current one (probably): https://community.f-secure.com/t5/Home-Security/TP138-Windows-Client-Release/m-p/70180

     

    Where was "fixed trouble": 'OAS and HIPS prompts unusable' ; Which can be related with your description... but probably you should be have more fresh installation (than was TP138) and there already was new updats with new Qt-library for UI and other...

     

    So... maybe there can be something else?! Maybe conflict with another software?! Or anything else.. but probably there required.. a support ticket maybe?!

     

    Sorry again for my reply and for not nice english.

  • Now i don't even get any prompts when i run LeakTest - what the hell is this now?

    and no, leaktest.exe is not found listed in "Application permissions".

     

    For some reason now that i run it, i get no prompts at all. How nice.

  • UkkoUkko Posts: 3,213 Superuser

    Hello,

     

    I have more funny situations around Leaktest and Deepguard (yesterday). But... I not check it more... and not sure about it was random or not. But it's three strange points about DeepGuard (and maybe not just aboue Leaktest).  Such as: Leaktest launched anyway (maybe not all feature, but launched UI), with additional steps... description for Leaktest goes be missing from DeepGuard storage information and after a "restart"... Leaktest simply goes to be missing from DeepGuard Storage/list.

     

    Your situation maybe can be related with next design:

     

    --> How I can remember and with my experience.

    If you allowed application or something around this (remove from DeepGuard storage or other).

    There can be temporary "freeze" for next prompt by DeepGuard.

    Such as... five minutes (as example) between new prompt. A little be stuck probably. But current design more valid for "trying to network connection" and I not check it with examples like Leaktest-prompt. But it's should not be... too much long maybe. For my experience.. leaktest still triggered DeepGuard pop-up.

     

    --> DeepGuard should always to create prompts - if you launch it (does not matter.. if there goes be launch-action after a small delay... seconds after previous launch) from various destination.

    From one destination can be stuck. Maybe related with cloud-design or optimisation for re-checks (by real-time).

     

    Sorry for my suggestions. Just as my experience around.

    Also.. if there Windows 10.. maybe it's just something as not compatible-result, which still can be there?

     

This discussion has been closed.